Bug #75883

Upgrade wizards (and possibly other parts) of the Install Tool fatal due to missing DI

Added by Jigal van Hemert almost 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Category:
Install Tool
Target version:
Start date:
2016-04-23
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

As a side effect of removing the Extbase object manager and using makeInstance instead the dependency injection doesn't work. This leads to fatal errors because the code assumes that objects are instantiated.


Related issues

Related to TYPO3 Core - Task #73605: Get rid of ObjectManager usages in install toolClosedClaus Due2016-02-22

Actions
#1

Updated by Philipp Gampe almost 5 years ago

I suggest do simply create the objects and call the inject methods manually.

#2

Updated by Jigal van Hemert almost 5 years ago

  • Assignee set to Jigal van Hemert

I'm creating a simple function that takes an array of class names, creates objects and calls the injection functions. This is hopefully enough to fix the missing dependencies.

#3

Updated by Gerrit Code Review almost 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47933

#4

Updated by Jigal van Hemert almost 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF