Bug #76106

RTE won't load in IE 9 or IE Edge - JS error appears

Added by Stefan Berger over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-05-10
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

when you open e.g. a text element in IE 9 or IE Edge the RTE won't load and a JS error appears.
See the attached screenshot from the current TYPO3 demo system.

Also in the newest TYPO3 version the problem exists.

screenshot.png View (218 KB) Stefan Berger, 2016-05-10 09:36

placeholders.jquery.min.js (18.2 KB) Tizian Schmidlin, 2016-05-25 11:33

Associated revisions

Revision 86ba3d99 (diff)
Added by Wouter Wolters about 2 years ago

[BUGFIX] Use native Placeholder.js intead of the jQuery adapter

Resolves: #76106
Releases: 7.6
Change-Id: I4e6c11263275c75bf899d32f35bcdeb488f9ed7b
Reviewed-on: https://review.typo3.org/48367
Reviewed-by: Robert van Kammen <>
Tested-by: Robert van Kammen <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Gianluigi Martino over 2 years ago

  • Status changed from New to Needs Feedback

i cannot reproduce this with IE Edge and Windows 10
tested with master (8.2.0) and 7.6.5

wich windows do you use?
can you check if you don't block some javascript?

#2 Updated by Marc Füßlein over 2 years ago

I do get the same JS errors in IE9.

At least for IE9 it seems to be a problem with Placeholders.js. By removing the minified javascript in Resources/Public/JavaScript/Contrib/placeholders.jquery.min.js the RTE loads again.

#3 Updated by Tizian Schmidlin about 2 years ago

I can totally relate.

Here's my version of the file (see attached).

First, there seems to be a problem with jQuery not beeing loaded properly, so I made sure everything was right by only executing it once the document was ready (this might be too much but anyway) and then I used TYPO3.jQuery to be sure to have no conflit.

Additionally I updated jQuery to 2.2.4.

PS: everything happens beginning on line 555. The major fix though is that also the line 563 has been improved to support browsers that do not have Placeholders.

#4 Updated by Gerrit Code Review about 2 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48367

#5 Updated by Wouter Wolters about 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF