Bug #76427

Exception when adding in a workspace a page in the pagetree

Added by R3 H6 over 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2016-06-01
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

It is not possible to add a page in workspace, if this page has a version in workspace and is set a mountpoint for workspace.
This error occurs in TYPO3 6.2, TYPO3 7.6

Situation

Pagetree:

+ Home (#1)
  + Site A (#10)
    + Site B (#11)

Workspace:
  1. Add "Site A" in page mountpoints. Swap into the workspace as a non admin user.
  2. Add a new page in the pagetree under "Site A" => OK
  3. Now edit "Site A" (Auto-created for WS #1, uid 48)
  4. Add an other new site under "Site A" => Exception*

*Exception [1.4.14]: Attempt to move record '[Default Title]' (pages:46) without having permissions to do so.

DB Dump (pages):

uid   pid   t3ver_oid   t3ver_id   t3ver_wsid   t3ver_label             t3ver_state
50    -1    49          1          1            First draft version      -1
49    48    0           0          1            INITIAL PLACEHOLDER      1
48    -1    10          1          1            Auto-created for WS #1   0
10    1     0           0          0                                     0

The error is that the initial placeholder (uid 49) gets the wrong pid, 48 instead of 10!

History

#1 Updated by Rafal Brzeski over 3 years ago

I can confirm that bug on TYPO3 7.6.16

#2 Updated by Riccardo De Contardi over 1 year ago

I tried to reproduce this issue on the latest master, but I failed; either I did something wrong or the issue is not present.

My Test:

Prerequisites

  • fresh TYPO3 installation (Latest master)
  • the following page structure:
+ Home (ID=1)
  + Site A (ID=10)
    + Site B (ID=11)
  • an "editors" group . with the following features:
    • ACL: Full control on all tables and fields
    • mount point: Home page (ID=1)
  • All the pages have group=editors with all privileges
  • an "editor" user, belonging to "editors" group.
  • a record of type workspace
    • title: draft
    • Owners: editors
    • Members: editors
    • DB Mounts: Site A (ID=10)

Test

1) switch to "editor"
2) switch to "draft" workspace
2.1) the pagetree correctly shows only the "Site A" page and its subpabes (worskpace mount point)
3) Add a new page in the pagetree under "Site A"
4) Edit "Site A" and change for example the subtitle; save and exit
5) Add a new page in the pagetree under "Site A"

Results
  • the page created at point 3) does not trigger any error
  • the page created at point 5) does not trigger any error

Am I missing something? Could you please tell us if this test procedure is correct?

#3 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from New to Needs Feedback

#4 Updated by Riccardo De Contardi over 1 year ago

I repeated the test I described on my comment 2 for

- TYPO3 7.6.32
- TYPO3 8.7.24
- TYPO3 9.5.5
- TYPO3 10.0.0-dev

The result is: it is still reproducible only for version 7.6.32

Is it sufficient to consider it closed or a different test should be performed?

#5 Updated by Benni Mack over 1 year ago

  • Target version changed from next-patchlevel to Candidate for patchlevel

#6 Updated by Riccardo De Contardi about 1 year ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (Candidate for patchlevel)

There has been no feedback for more than 90 days; plus, the issue seems not reproducible anymore on recent TYPO3 versions, therefore I think it is safe to close it.

If you think that this is the wrong decision or experience the issue again on recent TYPO3 versions, please reopen it or ping me; please add also if possible a step-by-step tutorial about how to reproduce the issue.

Thank you and best regards

Also available in: Atom PDF