Bug #76439

Table wizard does not work in Internet Explorer

Added by Manuel Link over 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2016-06-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

the table wizzard in the backend does not work as intended in Internet Explorer.
Klicking any of the row-buttons in the wizzard (e.g. add row) leads to the backend reloading in the current Frame.
removing the onclick-function of these buttons seems to resolve the issue. i am not sure what the onclick was supposed to do, but i am fairly sure it is not needed any more


Files

table_row_delete_error.png (33.4 KB) table_row_delete_error.png David Rellstab, 2016-06-03 16:33
#1

Updated by Wouter Wolters over 5 years ago

  • Subject changed from Table wizzard does not work in Internet Explorer to Table wizard does not work in Internet Explorer
  • Status changed from New to Needs Feedback

Can you check if you get an JavaScript error?

#2

Updated by David Rellstab over 5 years ago

Can confirm this, same Core/PHP Version, only with IE.

JS-Error (see screenshot), seems to be a nullpointer on TYPO3.STORAGE

#3

Updated by Wouter Wolters over 5 years ago

Can't reproduce here in IE. Which exact IE version do you use? And could you try latest 7.6 branch. We fixed an JS issue with IE last week.

#4

Updated by Gerhard Rupp over 5 years ago

Can reproduce this behaviour with Internet Explorer 11.306.10586.0 and TYPO3 7.6.9.

#5

Updated by Gerhard Rupp over 5 years ago

Tried current branch of 7.6 - bug is still present.

#6

Updated by Riccardo De Contardi over 5 years ago

Confirmed (plain 7.6.9, IE 11 11.0.9600.18314)

#7

Updated by Wouter Wolters over 5 years ago

Please try latest branch, not the 7.6.9. You need to clone the GIT repository of the 7.6 branch.

#8

Updated by Riccardo De Contardi about 5 years ago

  • Category set to Backend User Interface
#9

Updated by Wouter Wolters about 5 years ago

Still a problem?

#10

Updated by Riccardo De Contardi about 5 years ago

I've just performed a test with both 7.6.10 and 7.6.11-dev and IE11 11.0.9600.18314
I also tried with IE10 and IE9 (IE11 emulation)

Verdict: the bug seems not present anymore.

I noticed that when you click on the last "add row" "+" button, five rows will be added but I think it is intended, as this behavior is browser-independent and present even on 4.7.x

#11

Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from Needs Feedback to Closed

90 days without activity > closing this issue

If you think that this is the wrong decision or experience the issue again then please reopen it or open a new issue with a reference to this one. Thank you.

Also available in: Atom PDF