Project

General

Profile

Actions

Bug #77110

closed

In RTE, link title is broken (7.6 only, 6.2 works perfect)

Added by André Spindler almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2016-07-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

TYPO3 is 7.6.9. 6.2.25 is not affected.

There are two bugs:
1. Title gets not localized, although languge files have benn downloaded (verified). Labels in Wizard popup are translated.
2. Title field is filled with the title for first tab (internal page). When changing destination type to any other value, you always have "Opens internal link in current window".

Both features work well in 6.2.25. And this is annoying, when you have always to edit this by hand.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #78971: Link Wizard keeps title default value so the kind of link changesClosed2016-12-13

Actions
Actions #1

Updated by Markus Klein almost 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (next-patchlevel)

Can you please describe issue 1 in more detail please?
What is the default language of your website? Did you configure RTE.default.defaultContentLanguage = de properly?

Issue 2 is actually the intended functionality. The value of the title field is preserved, even if you switch the link type.
You don't want your custom text to vanish.

Actions #2

Updated by André Spindler almost 8 years ago

Issue 1 (localization):
This PageTS option RTE.default.defaultContentLanguage is new to me. I have never used it. If this is the reason, there must have been changes between 6.2 and 7.6, is it works with 6.2 without this optin being set. Not only in my config, but also as defualt value of the core.
Language setting:
Website has only one language: de
Frontend configuration is correct, but this should not have any effect as we are talking about BE context here.
All contents are defined in german, though, in pageTS this is set on root page (although not RTE related):
mod.SHARED.defaultLanguageFlag = de
mod.SHARED.defaultLanguageLabel = Deutsch
(This is for web/list module only)
German language data has completely been deleted and doenloaded again before submitting the ticket.
In user configuration for the editor german is set as language, and other labels (as far as translation done) are shown in german.

Issue 2 (different destination types):
Ok, if this behaviour was introduced in 7.6 in opposite to that in 6.2, it is not a bug. But then the entries in the localization files are obsolete, too. As they won't used any more.

Actions #3

Updated by André Spindler almost 8 years ago

Tested RTE option:
RTE.default.defaultContentLanguage = de works.
In this case there is only one content language. But what happens for different ones? Does the RTE plugin extract the language from the content record and the related sys_language entry?

Actions #4

Updated by Markus Klein almost 8 years ago

Issue 1:
The option is not new at all, it dates back way before 6.2.

Keep in mind that the chosen language for this title solely depends on the language assigned to the content element and nothing else!
This is why this option is needed as we have no other central TSconfig options which defines the locale of the default language.
For any other language the sys_languages table is conducted to retrieve the right locale.
Keep in mind that BE language is not equal content language!

Issue 2:
Not sure what you mean with "not used anymore".

Actions #5

Updated by André Spindler almost 8 years ago

Issue 1:
I know the difference between BE language and content language (of current data/record).
But why does this work in 6.2 then? When I change BE language for the editor in 6.2 and then insert a link, the title is also german. So 6.2 gets the correct language, but 7.6 not. Strange.

Issue 2:
I fist checked if the language files have been downloaded right. And there are labels in the xlf files for titles of all destination types. But when only the one for pages is used (and is not changed anymore as in 6.2), why are they still defined and included, but never used?
Got it? :-)

Actions #6

Updated by Markus Klein almost 8 years ago

Issue 1:
I didn't check with 6.2 by testing now, but briefly read the code => not much difference there.

When I change BE language for the editor in 6.2

Not sure what your original situation is in that case and to which language you switch. Please describe that in more detail.

Issue 2:
They are still used. If you switch to Email, and re-select the mail style, then the label is used.

Actions #7

Updated by Alexander Opitz over 7 years ago

@André Please answer to Markus else we will close this issue.

Actions #8

Updated by André Spindler over 7 years ago

I've checked this with TYPO3 7.6.12:

First issue is solved - Title is translated now.

The second issue is still there. Selecting the link style is no real solution here. Usually we define default link styles for every type. We need classes in all links to distinguish what link icon has to be shown: internal, external, file or mail. As editors always forget to define the style, it is predefined. But if there are default styles defined, after changing the link type you have to unselect the pre-selcted default style and select it again. Good usability is something different...

Actions #9

Updated by Markus Klein over 7 years ago

André, thanks for feedback. Still this is a matter of taste.
Where your usecase is to always have the default style selected, other wish that the currently selected class is preserved.
We can't provide both unless we introduce a new option, which would be a new feature only eligible for v8.

Changing the behaviour now in v7 could also be a "breaking change" for people being used to the current implementation.
I really have no idea what the right way is now.

Actions #10

Updated by André Spindler over 7 years ago

I agree that this might not be solved in 7.6.

Imho the best solution would be:

For link style:
No selector any more, but radio buttons with the following entries:
- (no class)
- all available classes, defined in rte config/TSconfig. Also showing which one is the default (if set)
Behaviour: When switching between link types, the default style should be selected if there is one for the current link type. If not, the former style should be kept if also available for the new type or switch to blank if not.
Only the class has to be stored, re-editing should then always be possible.

For link title:
Not just a single input field, but:
Also two radio buttons:
- one with the default title for links of current type
- one with an input field to keep an individual title
Therefore an editor can easily switch between both.
If the default title is stored als "LLL:[...]" string, and custon titles as default, this setting can also be re-edited, too.

Actions #11

Updated by Alexander Opitz over 7 years ago

@André

Ok, so would you be so nice and open a new feature request with your description?

So we have one thing per tracker and nobody will get mixed as there are 2 different things in this issue? After you open a new one, please write back here, so I can close this issue as resolved (as part 1 is solved like you wrote).

Thanks for your feedback.

Actions #12

Updated by Bernd Wilke over 7 years ago

As an editor complains about the wrong title-tags I noticed the changed behaviour and opened the ticket #78971.

Actions #13

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to Closed

Thanks Bernd, so closing this issue as part 1 of this is solved.

Actions

Also available in: Atom PDF