Bug #77181

Translation wizard must allow passing additional data

Added by Andreas Wolf over 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Start date:
2016-07-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Currently, the translation wizard in the page module only passes the colPos to the AJAX translation handler. For structures as defined by e.g. Gridelements or Flux, this is not enough, as the location inside the structure must be known to fetch elements for translating.

Also the additional data must be taken into account by the AJAX translation handler. This could be done either by changing the core translation handler to handle additional data (or call processors in a chain) or by overriding the handler with a custom Xclass in extensions like Flux or Gridelements.

#1

Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49437

#2

Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49437

#3

Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49437

#4

Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49437

#5

Updated by Gerrit Code Review over 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49437

#6

Updated by Gerrit Code Review over 4 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49437

#7

Updated by Gerrit Code Review over 4 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49437

#8

Updated by Wouter Wolters about 4 years ago

  • Status changed from Under Review to Closed
#9

Updated by Kevin Quiatkowski about 4 years ago

why is this marked as Solved? Making it deprecated in v8 will not resolve the bugs in v7.

#10

Updated by Gerrit Code Review over 3 years ago

  • Status changed from Closed to Under Review

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49437

#11

Updated by Gerrit Code Review over 3 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49437

#12

Updated by Gerrit Code Review almost 3 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49437

#13

Updated by Susanne Moog almost 2 years ago

  • Status changed from Under Review to Needs Feedback

Review has been abandoned. Please check if issue is still needed (see review comment).

#14

Updated by Tymoteusz Motylewski about 1 year ago

  • Status changed from Needs Feedback to Closed

closing issue due to lack of feedback

Also available in: Atom PDF