Bug #77972

Missing upload buttons in inline field

Added by Hendrik Putzek over 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-09-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If a backend field for inserting an image is configured like

<maxitems>1</maxitems>
<minitems>1</minitems>

the button to add a new relation is hidden by inline style "display:none". (Which is correct)

But if the image is deleted by using the trashcan icon, the upload button does not show up again.

This leads to the following behaviour:
  • Its not possible to save the form (validation says there must be at least one image)
  • Its not possible to add another image and therefore make the form valid because of the missing upload button

The Buttons are hidden in typo3/sysext/backend/Classes/Form/Container/InlineControlContainer.php:247

In https://forge.typo3.org/issues/45125 is stated that:
"The buttons are not immediately
hidden/shown if the number of relation changes. That would involve
JavaScript magic and could be done in a follow up."

That Javascript seems to be not implemented yet.


Steps to reproduce:

  • Create a flexform including an inline field for inserting an image.
    Set
    <maxitems>1</maxitems>
    <minitems>1</minitems>
    
  • Upload one image and save the form
  • The upload button is hidden
  • Delete the uploaded image using the trashcan icon
  • The upload button does not show up again

Related issues

Related to TYPO3 Core - Bug #45125: Hide "Create new relation" for FAL fields, if maxitems = 1 and an image is selectedClosedJan Helke2013-02-04

Actions
Related to TYPO3 Core - Bug #78479: FAL field (in flexform) with minitems=1 and maxitems=1 has no possibility to add image after deleting the previous oneClosed2016-10-28

Actions
Has duplicate TYPO3 Core - Bug #78379: Flexform FAL missing add button on image deleteRejected2016-10-22

Actions
#1

Updated by Hendrik Putzek over 5 years ago

  • Description updated (diff)
#2

Updated by Riccardo De Contardi over 3 years ago

  • Related to Bug #78479: FAL field (in flexform) with minitems=1 and maxitems=1 has no possibility to add image after deleting the previous one added
#3

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from New to Closed

I close this issue as I think it is a duplicate of #78479 please continue the discussion there.

If I am wrong, please reopen it or ping me. Thank you

Also available in: Atom PDF