Bug #78479

FAL field (in flexform) with minitems=1 and maxitems=1 has no possibility to add image after deleting the previous one

Added by Ge Rie almost 3 years ago. Updated over 2 years ago.

Status:
New
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2016-10-28
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Hi,
I've noticed a strange behavior when using File Abstraction Layer and set the maxitems. For example something like this:

  <minitems>1</minitems>
  <maxitems>1</maxitems>

There is no possibility to change the images later on because the "Add image" Button is missing (when the max allowed imagese are reached). If I delete an image there is still no button and therefore no change to add a new image.

Please see images attached for better understanding.

TYPO3 7.6.11
DCE 1.3.7

Thanks a lot!

01-maxitems-reached.jpg View - Maximal allowed items inserted (56.7 KB) Ge Rie, 2016-10-28 11:15

02-existing-image-deleted.jpg View - Image deleted afterwards - no possiblity to add new image (53.3 KB) Ge Rie, 2016-10-28 11:15

03-maxitems-raised-to-99.jpg View - maxitems raised to 99 and the button appears (60.3 KB) Ge Rie, 2016-10-28 11:15


Related issues

Related to TYPO3 Core - Bug #72294: Can't delete FAL image in flexform Closed 2015-12-17
Related to TYPO3 Core - Bug #77972: Missing upload buttons in inline field Closed 2016-09-16

History

#1 Updated by Armin Vieweg over 2 years ago

You are right this is a bug. But not in DCE, in TYPO3's form engine. It still occures in TYPO3 8.5. I remember that I've reported this bug 1-1,5 years ago and it was fixed... Had this case min=1/max=1 too. However, I move this issue to TYPO3 issue tracker. Thanks for reporting.

#2 Updated by Armin Vieweg over 2 years ago

  • Project changed from Dynamic Content Elements (DCE) to TYPO3 Core
  • Subject changed from File Abstraction Layer with maxitems - Add image Button missing to FAL field (in flexform) with minitems=1 and maxitems=1 has no possibility to add image after deleting the previous one
  • Category set to FormEngine aka TCEforms
  • TYPO3 Version changed from 7 to 8
  • PHP Version set to 7.0
  • Is Regression set to No

#3 Updated by Armin Vieweg over 2 years ago

  • Is Regression changed from No to Yes

#4 Updated by Armin Vieweg over 2 years ago

This issue has already been fixed (#72294) and occures again.

#5 Updated by Riccardo De Contardi about 1 year ago

  • Related to Bug #77972: Missing upload buttons in inline field added

Also available in: Atom PDF