Bug #78479

FAL field (in flexform) with minitems=1 and maxitems=1 has no possibility to add image after deleting the previous one

Added by Ge Rie about 5 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2016-10-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Hi,
I've noticed a strange behavior when using File Abstraction Layer and set the maxitems. For example something like this:

  <minitems>1</minitems>
  <maxitems>1</maxitems>

There is no possibility to change the images later on because the "Add image" Button is missing (when the max allowed imagese are reached). If I delete an image there is still no button and therefore no change to add a new image.

Please see images attached for better understanding.

TYPO3 7.6.11
DCE 1.3.7

Thanks a lot!


Files

01-maxitems-reached.jpg (56.7 KB) 01-maxitems-reached.jpg Maximal allowed items inserted Ge Rie, 2016-10-28 11:15
02-existing-image-deleted.jpg (53.3 KB) 02-existing-image-deleted.jpg Image deleted afterwards - no possiblity to add new image Ge Rie, 2016-10-28 11:15
03-maxitems-raised-to-99.jpg (60.3 KB) 03-maxitems-raised-to-99.jpg maxitems raised to 99 and the button appears Ge Rie, 2016-10-28 11:15

Related issues

Related to TYPO3 Core - Bug #72294: Can't delete FAL image in flexformClosedMorton Jonuschat2015-12-17

Actions
Related to TYPO3 Core - Bug #77972: Missing upload buttons in inline fieldClosed2016-09-16

Actions
Related to TYPO3 Core - Bug #92381: Button "Create new" does not re-appear for inline (IRRE) elements after reaching maxitems and removing one elementClosed2020-09-23

Actions
Related to TYPO3 Core - Bug #91808: Nested IRRE with maxitems hides last inline control button / toggles inline control buttons wrongClosed2020-07-16

Actions
#1

Updated by Armin Vieweg almost 5 years ago

You are right this is a bug. But not in DCE, in TYPO3's form engine. It still occures in TYPO3 8.5. I remember that I've reported this bug 1-1,5 years ago and it was fixed... Had this case min=1/max=1 too. However, I move this issue to TYPO3 issue tracker. Thanks for reporting.

#2

Updated by Armin Vieweg almost 5 years ago

  • Project changed from 2185 to TYPO3 Core
  • Subject changed from File Abstraction Layer with maxitems - Add image Button missing to FAL field (in flexform) with minitems=1 and maxitems=1 has no possibility to add image after deleting the previous one
  • Category set to FormEngine aka TCEforms
  • TYPO3 Version changed from 7 to 8
  • PHP Version set to 7.0
  • Is Regression set to No
#3

Updated by Armin Vieweg almost 5 years ago

  • Is Regression changed from No to Yes
#4

Updated by Armin Vieweg almost 5 years ago

This issue has already been fixed (#72294) and occures again.

#5

Updated by Riccardo De Contardi over 3 years ago

  • Related to Bug #77972: Missing upload buttons in inline field added
#6

Updated by Christian Buelter about 1 year ago

  • Related to Bug #92381: Button "Create new" does not re-appear for inline (IRRE) elements after reaching maxitems and removing one element added
#7

Updated by Oliver Bartsch about 1 year ago

  • Status changed from New to Closed

Hi, this is fixed with #91808. I will therefore close this issue. If you think there is still something not working, please let me know and I will re-open the ticket.

#8

Updated by Oliver Bartsch about 1 year ago

  • Related to Bug #91808: Nested IRRE with maxitems hides last inline control button / toggles inline control buttons wrong added
#9

Updated by Joachim Eckerlin 11 months ago

  • TYPO3 Version changed from 8 to 10
  • PHP Version changed from 7.0 to 7.3

Unfortunately I have to reopen this issue. It just happened again on a few projects, where the editor was not able to change the image, because the buttons did not reappear after deleting the old image.
because of minitems = 1 you are also not able to save to get the buttons back. So the only possibility to change the image is to delete the whole content element and create a new one with another image.
We solved it right now by setting minitems = 0 and telling the editors to please always add an image, but that is not the solution we would like to have ;)

#10

Updated by Jan Kornblum 9 months ago

I can confirm this is fixed in 10.4.13 with #91808 . Just testet.

Also available in: Atom PDF