Bug #78072

No possibility to choose database host -> resulting in error if mysql db is not on localhost

Added by Peter Proell almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2016-09-27
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When installing 8.3 on a domainfactory webspace the installer throws an error:

An exception occured in driver: Connecting to 3.22, 3.23 & 4.0 servers is not supported

This is because df has an old version of mysql on 127.0.0.1 and the v5 mysql is on 127.0.0.3. There is currently no possibility to specify the different server location before this error occurs or to enter a different server location when the error occurs.

Workaround:

When the error occurs change the Localconfiguration.php host value manually and then reload the installer with the error to proceed.


Related issues

Duplicates TYPO3 Core - Bug #76163: Predefined database host during installation Closed 2016-05-12

History

#1 Updated by Wouter Wolters almost 3 years ago

  • Status changed from New to Needs Feedback

Hi Peter, this is related to https://forge.typo3.org/issues/76163 which has been fixed on latest master. Can you if this is also solved for you on latest master?

#2 Updated by Christian Kuhn almost 3 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF