Bug #76163

Predefined database host during installation

Added by Wolfgang Wagner over 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2016-05-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I tried to install TYPO3 8.1.0 on a webserver.

In Step 2 to of the Installtool I got the error message

"An exception occured in driver: Connecting to 3.22, 323 & 4.0 servers is not supported"

It seems, that before step 2 a LocalConfiguration.php is created and as host 127.0.0.1 is inserted. That might work on local machines, but not on a real server, if you have to define a different host.
For example, on this server 127.0.0.1 addresses MySQL 3, but MySQL 5 needs 127.0.0.3

After manually editing the LocalConfiguration.php with the correct database parameters, the Installtool could continue.


Files

2016-05-12_13-39-44.png (27.5 KB) 2016-05-12_13-39-44.png Wolfgang Wagner, 2016-05-12 13:51

Related issues

Related to TYPO3 Core - Bug #76185: Install tool not working when NOT using namebased hostingClosed2016-05-13

Actions
Has duplicate TYPO3 Core - Bug #77725: Install-Tools stops when localhost is not the DB serverClosed2016-08-31

Actions
Has duplicate TYPO3 Core - Bug #78072: No possibility to choose database host -> resulting in error if mysql db is not on localhostClosed2016-09-27

Actions
#1

Updated by Anja Leichsenring over 5 years ago

Hi Wolfgang, in the first step you are to provide the host as a string. What have you entered there?

#2

Updated by Wolfgang Wagner over 5 years ago

No, I could not enter any credentials here. The error message appeared directly after "The System looks good..."

#4

Updated by Anja Leichsenring over 5 years ago

boom! :D Thank you. Investigating.

#5

Updated by Riccardo De Contardi about 5 years ago

  • Category set to Install Tool
#6

Updated by Stefan Froemken about 5 years ago

  • Status changed from New to Accepted

I have changed the IP 127.0.0.1 to a non existing local IP address directly in core and started the FIRST_INSTALL script. Showing the DB form needs round about 30 seconds. I'm sure it tries to connect to DB without knowing the correct credencials. It can't connect and shows the form, but it does not throws an Exception.
On our servers 127.0.0.1 with port 3306 is a MySQL 3 engine. Maybe it throws errors because mysqli is not able to connect to MySQL3 anymore.

2 possibilities:

- Don't try to connect to whatever server before showing the form.
- catch failing connections

I prefer first one, because no one understands why he has to wait up to 30 seconds for a little form.

Stefan

#7

Updated by Gerrit Code Review about 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49249

#8

Updated by Gerrit Code Review about 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49249

#9

Updated by Jigal van Hemert about 5 years ago

This part of the Install Tool will be rewritten before 8 LTS.

#10

Updated by Morton Jonuschat about 5 years ago

  • Status changed from Under Review to Closed

Fixed on latest master.

Also available in: Atom PDF