Bug #78857

RTE right click context menu appears misplaced, below the editor by far and hardly reachable

Added by Alexander Stehlik almost 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2016-12-01
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

When using right click in the RTE nothing happens.

Seems to be caused by the ExtJS removal: #52877

screenshot_rte.png View (24 KB) Alexander Stehlik, 2017-01-10 23:13


Related issues

Related to TYPO3 Core - Bug #52877: replace extjs panels with pure css and get rid of the overhead Closed 2013-10-16

History

#1 Updated by Riccardo De Contardi over 2 years ago

  • Description updated (diff)
  • Status changed from New to Needs Feedback

@Alexander Stehlik

Can you test it with an empty RTE? I've tested it on 8.5.0 and the RTE context menu is present, but misplaced.

I think that the related issue is this one https://forge.typo3.org/issues/78001 which has been solved only for 7.6 as far as I can see

#2 Updated by Alexander Stehlik over 2 years ago

I just tested it again. The menu opens again but there is a new problem:

It is displayed way below the editor and can hardly be reached (see attached screenshot).

Edit: Tested in Chrome and Firefox.

#3 Updated by Riccardo De Contardi over 2 years ago

  • Subject changed from RTE right click context menu does not work any more to RTE right click context menu appears misplaced, below the editor by far and hardly reachable
  • Status changed from Needs Feedback to New

As I said, it could be a revamp of this one: #78001 (but I don't know exactly, maybe that's not related, even if the effects seems the same)

#4 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from New to Closed

Closing. This does not affect anymore TYPO3 8, and seems already solved for version 7.6.

If you experience the issue again with version 7.6 please reopen it or open a new issue with a reference to this one;
If you still need it for version 8, where RTEHtmlarea has been removed, open an issue on https://github.com/FriendsOfTYPO3/rtehtmlarea if you still experience the issue. Thank you.

Also available in: Atom PDF