Bug #52877

Epic #55575: Streamline JavaScript Code in the TYPO3 Backend

replace extjs panels with pure css and get rid of the overhead

Added by Kay Strobach over 5 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Code Cleanup
Target version:
Start date:
2013-10-16
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
On Location Sprint

Description

using e.g. bootstrap grid and some additional styling / jquery can dramatically reduce the complexity of the backend markup.
In a first step we can remove the layouts of extjs and lateron the panels as well ...


Related issues

Related to TYPO3 Core - Bug #78249: acceptance tests fails on main frame name Closed 2016-10-11
Related to TYPO3 Core - Bug #78273: Acceptance test fails on topbar bookmark Closed 2016-10-12
Related to TYPO3 Core - Bug #78272: Acceptance test fails on topbar flush cache Closed 2016-10-12
Related to TYPO3 Core - Bug #78286: Main module refresh Closed 2016-10-13
Related to TYPO3 Core - Bug #78287: Acceptance tests failing due to module menu selector changes Closed 2016-10-13
Related to TYPO3 Core - Bug #78297: Sanitize loading first module Closed 2016-10-14
Related to TYPO3 Core - Bug #78401: Workspaces preview page is broken Closed 2016-10-24
Related to TYPO3 Core - Bug #78857: RTE right click context menu appears misplaced, below the editor by far and hardly reachable Closed 2016-12-01
Related to TYPO3 Core - Bug #78476: "Mount as treeroot" triggers various errors Closed 2016-10-28

Associated revisions

Revision 9b7ed3ae (diff)
Added by Kay Strobach over 2 years ago

[!!!][TASK] Make the TYPO3 Backend responsive and remove ExtJS Viewport

A responsive CSS viewport replaces the legacy the ExtJS
component TYPO3.Viewport.

Resolves: #52877
Releases: master
Change-Id: I6d9c6c4e32cf67df3eeb072448e6b4322853d10c
Reviewed-on: https://review.typo3.org/47637
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

Revision 5d99bd32 (diff)
Added by Joerg Kummer over 2 years ago

[BUGFIX] Acceptance tests fails on main frame name

The viewport patch from issue #52877 renamed the content
iframe from "content" to "contentIframe". The patch changes
that in the acceptance tests, too.

Resolves: #78249
Related: #52877
Releases: master
Change-Id: Ia17ae9ee4a72e0f1d0a537e1ae575543b6b50188
Reviewed-on: https://review.typo3.org/50188
Tested-by: TYPO3com <>
Reviewed-by: Daniel Goerz <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision 18e53b04 (diff)
Added by Andreas Fernandez over 2 years ago

[BUGFIX] Use correct element for `TYPO3.Backend.ContentContainer.getUrl()`

`TYPO3.Backend.ContentContainer.setUrl()` writes the URL into a different
element than `TYPO3.Backend.ContentContainer.getUrl()` tries to read,
resulting in a wrong URL.

This patch changes the behavior of `getUrl()` to read the URL from the
correct element.

Resolves: #78229
Related: #52877
Releases: master
Change-Id: Ie70c89d4a195fd37b18c11a86d2a672760430621
Reviewed-on: https://review.typo3.org/50204
Tested-by: TYPO3com <>
Tested-by: Riccardo De Contardi <>
Reviewed-by: Daniel Goerz <>
Tested-by: Daniel Goerz <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>

Revision c470f416 (diff)
Added by Andreas Fernandez over 2 years ago

[BUGFIX] Re-introduce `top.TYPO3.Backend.NavigationContainer.PageTree`

This patch re-adds the `top.TYPO3.Backend.NavigationContainer.PageTree`
object that is required to execute the `updatePageTree` signal
successfully. With this patch, the page tree gets updated again after
saving anything that triggers the signal.

Resolves: #78228
Related: #52877
Releases: master
Change-Id: I07c661dec68bb9b51470c8edbf3ac6643ab96cd9
Reviewed-on: https://review.typo3.org/50201
Tested-by: TYPO3com <>
Tested-by: Riccardo De Contardi <>
Reviewed-by: Daniel Goerz <>
Tested-by: Daniel Goerz <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>

Revision f20de408 (diff)
Added by Joerg Kummer over 2 years ago

[BUGFIX] Fix failing acceptance test on topbar flush cache

Adapt viewport changes in the acceptance tests too

Resolves: #78272
Related: #52877
Releases: master
Change-Id: I6940076bf747aea403d84b02f7a9d571064419b9
Reviewed-on: https://review.typo3.org/50202
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision 42e2a93d (diff)
Added by Joerg Kummer over 2 years ago

[BUGFIX] Fix failing acceptance test on topbar bookmark

Adapt viewport changes in the acceptance tests too.

Resolves: #78273
Related: #52877
Releases: master
Change-Id: Ie627372e24af90a235794181841265c5ca7d2ed7
Reviewed-on: https://review.typo3.org/50203
Tested-by: TYPO3com <>
Reviewed-by: Joerg Kummer <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision d31544a8 (diff)
Added by Christian Kuhn over 2 years ago

[BUGFIX] Main module ajax refresh

The main module id has been renamed from #typo3-menu to #menu.
Adapt that in JS to successfully reload the main module if
for instance an extension in loaded or unloaded in em.

Change-Id: Ie3c3600cc52ea4ca630b2642d84b045ef75f8528
Resolves: #78286
Related: #52877
Releases: master
Reviewed-on: https://review.typo3.org/50216
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>

Revision 200e0337 (diff)
Added by Wouter Wolters over 2 years ago

[BUGFIX] Sanitize loading first module

Suppress an invalid content iframe call if a
user logs in with no access rights to main modules.

Resolves: #78297
Related: #52877
Releases: master
Change-Id: I909ad485b55f2769959076011338fed2ec5a4758
Reviewed-on: https://review.typo3.org/50227
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Tested-by: TYPO3com <>
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>

Revision 0b756513 (diff)
Added by Christian Kuhn over 2 years ago

[BUGFIX] Acceptance tests fails due to viewport changes

Fix a couple of acceptance test selectors to adapt to
viewport changes.

Change-Id: I72050096c5c01134af2416f6610b416a2b9771b7
Resolves: #78287
Related: #52877
Releases: master
Reviewed-on: https://review.typo3.org/50217
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Mathias Schreiber over 4 years ago

  • Target version changed from 7.0 to 7.1 (Cleanup)

#2 Updated by Benni Mack about 4 years ago

  • Target version changed from 7.1 (Cleanup) to 7.4 (Backend)

#3 Updated by Wouter Wolters almost 4 years ago

  • Subject changed from replace extjs panels with pure css and get rid of the overhead :D to replace extjs panels with pure css and get rid of the overhead

#4 Updated by Susanne Moog almost 4 years ago

  • Target version changed from 7.4 (Backend) to 7.5

#5 Updated by Benni Mack over 3 years ago

  • Target version changed from 7.5 to 7 LTS

#6 Updated by Benni Mack over 3 years ago

  • Target version changed from 7 LTS to 8 LTS

#7 Updated by Riccardo De Contardi over 3 years ago

  • Category set to Code Cleanup

#8 Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#9 Updated by Gerrit Code Review about 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#10 Updated by Gerrit Code Review about 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#11 Updated by Gerrit Code Review about 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#12 Updated by Gerrit Code Review about 3 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#13 Updated by Gerrit Code Review about 3 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#14 Updated by Gerrit Code Review about 3 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#15 Updated by Gerrit Code Review about 3 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#16 Updated by Gerrit Code Review about 3 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#17 Updated by Gerrit Code Review about 3 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#18 Updated by Gerrit Code Review about 3 years ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#19 Updated by Gerrit Code Review about 3 years ago

Patch set 12 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#20 Updated by Gerrit Code Review about 3 years ago

Patch set 13 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#21 Updated by Gerrit Code Review about 3 years ago

Patch set 14 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#22 Updated by Gerrit Code Review about 3 years ago

Patch set 15 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#23 Updated by Gerrit Code Review about 3 years ago

Patch set 16 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#24 Updated by Gerrit Code Review about 3 years ago

Patch set 17 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#25 Updated by Gerrit Code Review about 3 years ago

Patch set 18 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#26 Updated by Gerrit Code Review about 3 years ago

Patch set 19 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#27 Updated by Gerrit Code Review about 3 years ago

Patch set 20 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#28 Updated by Gerrit Code Review about 3 years ago

Patch set 21 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#29 Updated by Gerrit Code Review about 3 years ago

Patch set 22 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#30 Updated by Riccardo De Contardi about 3 years ago

  • Parent task set to #55575

#31 Updated by Gerrit Code Review almost 3 years ago

Patch set 23 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#32 Updated by Benni Mack almost 3 years ago

  • Sprint Focus set to On Location Sprint

#33 Updated by Gerrit Code Review almost 3 years ago

Patch set 24 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#34 Updated by Gerrit Code Review almost 3 years ago

Patch set 25 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#35 Updated by Gerrit Code Review almost 3 years ago

Patch set 26 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#36 Updated by Gerrit Code Review almost 3 years ago

Patch set 27 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#37 Updated by Gerrit Code Review almost 3 years ago

Patch set 28 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#38 Updated by Gerrit Code Review almost 3 years ago

Patch set 29 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#39 Updated by Gerrit Code Review almost 3 years ago

Patch set 30 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#40 Updated by Gerrit Code Review almost 3 years ago

Patch set 31 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#41 Updated by Gerrit Code Review almost 3 years ago

Patch set 32 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#42 Updated by Gerrit Code Review almost 3 years ago

Patch set 33 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#43 Updated by Gerrit Code Review almost 3 years ago

Patch set 34 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#44 Updated by Gerrit Code Review almost 3 years ago

Patch set 35 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#45 Updated by Gerrit Code Review over 2 years ago

Patch set 36 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#46 Updated by Gerrit Code Review over 2 years ago

Patch set 37 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#47 Updated by Gerrit Code Review over 2 years ago

Patch set 38 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#48 Updated by Gerrit Code Review over 2 years ago

Patch set 39 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#49 Updated by Gerrit Code Review over 2 years ago

Patch set 40 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#50 Updated by Gerrit Code Review over 2 years ago

Patch set 41 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#51 Updated by Gerrit Code Review over 2 years ago

Patch set 42 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#52 Updated by Gerrit Code Review over 2 years ago

Patch set 43 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#53 Updated by Gerrit Code Review over 2 years ago

Patch set 44 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#54 Updated by Gerrit Code Review over 2 years ago

Patch set 45 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#55 Updated by Gerrit Code Review over 2 years ago

Patch set 46 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#56 Updated by Gerrit Code Review over 2 years ago

Patch set 47 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#57 Updated by Gerrit Code Review over 2 years ago

Patch set 48 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#58 Updated by Gerrit Code Review over 2 years ago

Patch set 49 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#59 Updated by Gerrit Code Review over 2 years ago

Patch set 50 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#60 Updated by Gerrit Code Review over 2 years ago

Patch set 51 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#61 Updated by Gerrit Code Review over 2 years ago

Patch set 52 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#62 Updated by Gerrit Code Review over 2 years ago

Patch set 53 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#63 Updated by Gerrit Code Review over 2 years ago

Patch set 54 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47637

#64 Updated by Anonymous over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#65 Updated by Wolfgang Klinger almost 2 years ago

  • Related to Bug #78476: "Mount as treeroot" triggers various errors added

#66 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF