Bug #79329

return_id param passed to permissions module is not evaluated

Added by Tymoteusz Motylewski over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend API
Target version:
-
Start date:
2017-01-15
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

During the permissions module refactoring http://review.typo3.org/33402 the code or the permissions module has hanged a lot.

In 2 places in the core (ClickMenu, DatabaseRecordList) the link to the permissions module contains `return_id` and `edit` parameters additionally to the `id` parameter.

However the permissions module is not evaluating `return_id` nor `edit` parameter.
It check for `returnId` (without underscore) param, however I'm not sure if it has the same meaning as the old `return_id`.
The question is, whether I can drop `return_id` usage,or should it be converted to `returnId` or sth else should happen?
Second question - is the "edit" parameter necessary, or should I drop it or adapt it to some new name?

Associated revisions

Revision 81799a43 (diff)
Added by Frank Naegler over 2 years ago

[BUGFIX] Fix broken links to permission module

This patch fix broken links in ClickMenu and DatabaseRecordList which
exists since the permissions module refactoring:
http://review.typo3.org/33402

Resolves: #79329
Related: #62339
Releases: master, 7.6
Change-Id: Iafe66352a7bac593e249ef09c07f1c9dc9b15359
Reviewed-on: https://review.typo3.org/51330
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Mona Muzaffar <>
Tested-by: Mona Muzaffar <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

Revision 131586ad (diff)
Added by Frank Naegler over 2 years ago

[BUGFIX] Fix broken links to permission module

This patch fix broken links in ClickMenu and DatabaseRecordList which
exists since the permissions module refactoring:
http://review.typo3.org/33402

Resolves: #79329
Related: #62339
Releases: master, 7.6
Change-Id: Iafe66352a7bac593e249ef09c07f1c9dc9b15359
Reviewed-on: https://review.typo3.org/51401
Tested-by: TYPO3com <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

History

#1 Updated by Frank Naegler over 2 years ago

  • Category set to Backend API
  • Status changed from New to Accepted
  • Assignee set to Frank Naegler

Thanks for your report, after a quick check this must be changed:

1) the parameter return_id must be changed to returnId
2) the parameter edit must be changed to tx_beuser_system_beusertxpermission[action]=edit

I will provide a patch this evening.

#2 Updated by Gerrit Code Review over 2 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51330

#3 Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51330

#4 Updated by Gerrit Code Review over 2 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51401

#5 Updated by Frank Naegler over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF