Bug #79606

New page version not displayed in the pagetree if it is under PID=0

Added by Sergio Catalá over 2 years ago. Updated 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2017-02-02
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Working with workspaces, I created a Page 4 under PID=0 (same level as Root page in the picture). The page is there and it exists in the database (as you can see in the right part). However, the pagetree doesn't render the page there (but it does with a Page 5 under Root page). Is this a bug or a desired behaviour for some reason?

workspaces.png View (36.8 KB) Sergio Catalá, 2017-02-02 17:01

Associated revisions

Revision b3c17046 (diff)
Added by Benni Mack 6 months ago

[BUGFIX] Fix various "No pseudo-site found in root line of page" errors

Fixes workspace resolving etc.

The !empty statement is wrong as a string value "0" would not expect the
right return. This fixes the detection of l10n_parent.
Also check for sys_language_uid, too, to get the pid of the record
instead of its parent.

This also fixes opening categories (sys_category) when using EXT:news,
which calls this condition in TCA:
'displayCond' => 'USER:' . \TYPO3\CMS\Core\Compatibility\
PseudoSiteTcaDisplayCondition::class . '->isInPseudoSite:pages:false',

Check array index exists in SiteResolving.

Resolves: #79606
Resolves: #86186
Resolves: #86622
Resolves: #86678
Resolves: #86684
Releases: master, 9.5
Change-Id: If3ddf5eead2dddd51db3bcf751d71d3bc362ef35
Reviewed-on: https://review.typo3.org/59229
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

Revision aa08d433 (diff)
Added by Benni Mack 6 months ago

[BUGFIX] Fix various "No pseudo-site found in root line of page" errors

Fixes workspace resolving etc.

The !empty statement is wrong as a string value "0" would not expect the
right return. This fixes the detection of l10n_parent.
Also check for sys_language_uid, too, to get the pid of the record
instead of its parent.

This also fixes opening categories (sys_category) when using EXT:news,
which calls this condition in TCA:
'displayCond' => 'USER:' . \TYPO3\CMS\Core\Compatibility\
PseudoSiteTcaDisplayCondition::class . '->isInPseudoSite:pages:false',

Check array index exists in SiteResolving.

Resolves: #79606
Resolves: #86186
Resolves: #86622
Resolves: #86678
Resolves: #86684
Releases: master, 9.5
Change-Id: If3ddf5eead2dddd51db3bcf751d71d3bc362ef35
Reviewed-on: https://review.typo3.org/59453
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Riccardo De Contardi almost 2 years ago

  • Category set to Pagetree

It is still present 8.7.x

Steps to reproduce

1) Live worskspace
1.1) create a new page at the same level of the root page (It does not matter if it is marked as root)
2) switch to a custom workpace

Result

the page created at 1.1 is not visible in pagetree.

#2 Updated by Riccardo De Contardi about 1 year ago

Also present on 9.3.0-dev (latest master)

#3 Updated by Riccardo De Contardi 8 months ago

  • Status changed from New to Needs Feedback

@Sergio Catalá When I tested this issue the last time I have not considered that when you create a workspace, you set a mount point so, if you use the "home" page under the root (id=0) as mount point, all other pages at the same level will be absent.

On the v.9 pagetree, the root (ID=0) node is even not shown when in workspaces.

So, this seems an intended behavior, or do I miss something ?

#4 Updated by Sergio Catalá 8 months ago

You're totally right about the mountpoint, Riccardo. This should be an intended behaviour.
However, doesn't it make more sense not to even allow the creation of that page on the same level as page under root uid=0?

#5 Updated by Riccardo De Contardi 8 months ago

at this point I think that this issue is becoming a more general one than that; I guess (can't test right now) that you would have the same issue

- even if your mountpoint is at another level different from 1
- and I think that it is even possible that it comes up even without workspaces at all, if your user or usergroup has a mountpoint and you try to create a page in parallel to that mountpoint (I repeat, I can't test right now, I'm just guessing)

I don't know if it would be possible to disallow every case...
Maybe it would be better to show a warning? "You are trying to create a page, but based on your current configuration, you won't be able to see it"; I don't know.

[UPDATE]

so far, I have performed the following tests with TYPO3 9.5.2-dev (latest master)

test 1 (done with admin user)

1) create a workspace and set the homepage as mount point
2) switch to workspace
3) right-click on homepage > create new page
4) save the new page

Result

problem #1 the page is actually created, but not visible

problem #2 it throws an error:

(1/1) #1534710048 TYPO3\CMS\Core\Exception\SiteNotFoundException
No pseudo-site found in root line of page 889

Problem #3 the new page is visible even on LIVE workspace (and it should not be)

Problem #4 it is not possible to delete the page via the context menu of the pagetree (but other means of deleting it, like the list view, work)

Test 2 (done with non-admin user)

1) Use a non-admin user with a mount point
2) right-click on the mount point page > create new page

Result: it is not possible to create the page

Sorry, you didn't have proper permissions to perform this change.

No page new permission for user 2 on page 1437745640

Are there other tests/scenarios that comes in your mind?

#6 Updated by Gerrit Code Review 6 months ago

  • Status changed from Needs Feedback to Under Review

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59229

#7 Updated by Gerrit Code Review 6 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59453

#8 Updated by Benni Mack 6 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Benni Mack 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF