Bug #79872

records throw an error on language -1

Added by König David over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Localization
Target version:
Start date:
2017-02-17
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

If I try to save a sys_category in TYPO3 8.6 with selected language "all" (-1) it throws an error.

There is no problem with saving the record in an other language.

The problem was not presented in TYPO3 8.5, and occurs on every Record witch have a field configured as "group".

On other records you can save with language "all". But if you try to change back to default or any other language, it falls back to "all". (i.e. file_colection)

The error message:

Argument 3 passed to TYPO3\CMS\Core\DataHandling\Localization\DataMapProcessor::synchronizeFieldValues() must be of the type array, null given, called in /opt/T3src/TYPO3.CMS_8.x/typo3/sysext/core/Classes/DataHandling/Localization/DataMapProcessor.php on line 253 

sys_category-error.png View - Error on trying save sys_category with language -1 (115 KB) König David, 2017-02-17 11:16


Related issues

Related to TYPO3 Core - Bug #79853: Exception when setting "Language" to "all" for new and/or existing content elements in backend Closed 2017-02-16

History

#1 Updated by Georg Ringer over 2 years ago

  • Subject changed from sys_category throws an Error on language -1 to records throw an error on language -1
  • Category set to Localization
  • Status changed from New to Accepted
  • Sprint Focus set to Stabilization Sprint

#2 Updated by Joerg Kummer over 2 years ago

Working on it at T3Sprint.

#3 Updated by Gerrit Code Review over 2 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51806

#4 Updated by Joerg Kummer over 2 years ago

  • Status changed from Under Review to Closed

Closed since there is another ticket with the same issue (see related).
Already applied in changeset f52349adfe90f13fccbac3fec41edb3d82de40b4.

Also available in: Atom PDF