Project

General

Profile

Actions

Bug #80172

closed

"group" TCA field prefills wrong items if relations exist

Added by Bianca Gotthart over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
DataHandler aka TCEmain
Target version:
Start date:
2017-03-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:
Stabilization Sprint

Description

There is a problem with the TCA type="group" when a new records is created and there are already saved relations in the database.
All existing relations from the mm tables are automatically added to the items field.

I found the problem while using sys_categroy, if there are already existing category-relations in the database.

1. create sy_category
2. create any random data (tt_content, news,...) and add a category relation to that.
3. create a new sys_category -> items are prefilled with the data in the sys_category_relation_mm

The problem is, that the new data has no numeric UID and in the RelationHandler->readMM class the where clause is only set for the uid, if it is an integer (MathUtility::canBeInterpretedAsInteger($uid)).


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #79455: Relationhandler queries database with non-numeric uidsClosedManuel Selbach2017-01-25

Actions
Related to TYPO3 Core - Bug #80360: Category bug with TYPO3 v8.6.1Closed2017-03-20

Actions
Actions #1

Updated by Bianca Gotthart over 7 years ago

  • Priority changed from Should have to -- undefined --
Actions #2

Updated by Markus Klein over 7 years ago

  • Category set to FormEngine aka TCEforms
  • Status changed from New to Accepted
  • Priority changed from -- undefined -- to Must have
  • Is Regression changed from No to Yes
  • Sprint Focus set to Stabilization Sprint
Actions #3

Updated by Oliver Hader over 7 years ago

This is caused by changes of issue #79455 which only applies a constraint in RelationHandler if the $uid value is numeric.
See https://review.typo3.org/#/c/51396/3/typo3/sysext/core/Classes/Database/RelationHandler.php

Actions #4

Updated by Oliver Hader over 7 years ago

  • Category changed from FormEngine aka TCEforms to DataHandler aka TCEmain
Actions #5

Updated by Gerrit Code Review over 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51978

Actions #6

Updated by Oliver Hader over 7 years ago

  • Status changed from Under Review to Closed

Handled as follow-up of #79455

Actions #7

Updated by Oliver Hader over 7 years ago

  • Status changed from Closed to Under Review

Still pending, thus reopened

Actions #9

Updated by Oliver Hader about 7 years ago

  • Status changed from Under Review to Resolved
  • Assignee set to Oliver Hader
Actions #10

Updated by Oliver Hader about 7 years ago

  • % Done changed from 0 to 100
Actions #11

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF