Bug #80300

CKEDITOR should be able to pick local image

Added by Anders Kostending over 2 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-03-16
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

When you insert an image in CKEDITOR you can only insert a link for an image. This should be the same as in rtehtmlarea, where you can pick an image in TYPO3.


Related issues

Related to TYPO3 Core - Bug #80823: CKEDITOR should be able to pick local image Rejected 2017-04-12

History

#1 Updated by Christian Kuhn over 2 years ago

  • Status changed from New to Rejected

No. Aligned with Benni here: Image handling within ckeditor will not be added to the core as it has been with rtehtmlarea. The image handling in rtehtmlarea has always been pita and the improved FAL handling with text/image and text/media obsolete that.
If you really need that (for instance for migrations), this should be done as an optional extension that will most probably not find its way into the core, along with all the nasty softref parsing and similar.

#2 Updated by René Fritz over 2 years ago

I see your point, but still I want to comment on that.

Editors use the inline images, and that's because editing a document on a page with multiple images is a pain using multiple records "Text & Media".
Editing means to edit content, not to put content on the page. Therefore you change content, which means you have to edit multiple records and copy & paste between them. This is just a pain, really.
Editors don't care about records, ce types and plugins.

So I understand not implementing inline images, but I think the inline images are not the problem but the lack of a document model in TYPO3.

The whole xml ecosystem can do things like that (with DTD, Schema, xsl etc.) but xml is no longer hip enough for some unknown reasons.

I think what TYPO3 needs is a full page editor (maybe FE editing will do that?) with a proper document model (which can be extended by extensions). Something like that exists in the DITA world with Wysiwym editors for example. (So it's possible)

The CKeditor creators think in the same direction. Would be nice if TYPO3 will do the same.

#3 Updated by Christian Kuhn over 2 years ago

  • Related to Bug #80823: CKEDITOR should be able to pick local image added

#5 Updated by Clemens Riccabona almost 2 years ago

Riccardo De Contardi wrote:

I see that there is an extension: https://github.com/netresearch/t3x-rte-ckeditor-image

The extension works.
But overall this is really just unbelievable ...
I need a 3rd party extension now, to deliver standards functionality ...

Also available in: Atom PDF