Bug #80561

TCA l18n_parent type "group" wont show original values in forms

Added by Klaus Hinum about 3 years ago. Updated 5 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2017-03-29
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Setting a translation parent (l18n_parent on default) in TCA to "group" disables the view of the original entries in the forms. Only

"type" => "group",
"internal_type" => "db",

Only 'type' => 'select' works

History

#1 Updated by Oliver Hader about 3 years ago

  • Status changed from New to Needs Feedback

Can you please provide the full configuration in TCA for that field?

#2 Updated by Klaus Hinum about 3 years ago

'l18n_parent' => array (
'displayCond' => 'FIELD:sys_language_uid:>:0',
'exclude' => 1,
'label' => 'LLL:EXT:lang/locallang_general.xml:LGL.l18n_parent',
"config" => Array (
"type" => "group",
"internal_type" => "db",
"allowed" => "tx_nbc2_chipset",
"size" => 1,
"minitems" => 0,
"maxitems" => 1,
'wizards' => array(
'suggest' => array(
'type' => 'suggest',
'default' => array(
'searchCondition' => 'sys_language_uid IN (-1,0)',
),
),
),
)
),

for example, but changing just the field from select to group and internal_type to db without the wizard also breaks it.

#3 Updated by Riccardo De Contardi almost 3 years ago

  • Status changed from Needs Feedback to New

#4 Updated by Markus Klein 11 months ago

  • Status changed from New to Needs Feedback

This seems to work on v8+

#5 Updated by Christian Eßl 8 months ago

  • Category set to FormEngine aka TCEforms

#6 Updated by Riccardo De Contardi 5 months ago

  • Status changed from Needs Feedback to Closed

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or open a new issue with a reference to this one.

Thank you and best regards

Also available in: Atom PDF