Bug #80660

TCA show userfunc columns

Added by Harald Holzmann over 3 years ago. Updated 4 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2017-04-03
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I have a TCA-Configured column as a user-func. Here is my configuration:

'image_view' => array(
    'exclude' => 1,
    'label' => 'Bild',
    'config' => array(
        'type' => 'user',
        'userFunc' => Varioous\VaSocial\Tca\HelperUtility::class . '->getImage'
    )
)

Now I go to the Backend-List-View. I enable this column to view it in the list view (where uid, hidden etc. is). After applying there comes the message "No data on this page". Because the image_view column makes problems.

I have to comment this column in the tca-configuration -> clear caches and then everything works again.

Should not lead to this error, better error message or gray user_func fields out so you cannot hick them.


Related issues

Related to TYPO3 Core - Bug #86092: Do not fetch type=none fields from db in list module Closed 2018-09-03

History

#1 Updated by Harald Holzmann about 3 years ago

  • Assignee set to Georg Ringer

#2 Updated by Georg Ringer almost 3 years ago

  • Assignee deleted (Georg Ringer)

#3 Updated by Georg Ringer almost 2 years ago

  • Related to Bug #86092: Do not fetch type=none fields from db in list module added

#4 Updated by Christian Eßl about 1 year ago

  • Category set to Backend API

#5 Updated by Christian Eßl 8 months ago

Can't reproduce this problem on TYPO3 10 master.

#6 Updated by Susanne Moog 8 months ago

  • Status changed from New to Needs Feedback

See last comment: Any more hints on how to reproduce the issue on current systems? Do you maybe have an example extension?

#7 Updated by Riccardo De Contardi 4 months ago

  • Status changed from Needs Feedback to Closed

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or open a new issue with a reference to this one.

Thank you and best regards

Also available in: Atom PDF