Task #80716

Epic #80700: Remove deprecated code from the core

Remove deprecated code from ext:core

Added by Wouter Wolters over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
Code Cleanup
Target version:
-
Start date:
2017-04-05
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

sysext/core/Resources/PHP/RemoveXSS.php:24: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9
sysext/core/Resources/PHP/RemoveXSS.php:36: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9
sysext/core/Resources/Public/JavaScript/QueryGenerator.js:17: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9
sysext/core/Tests/Unit/Configuration/FlexForm/FlexFormToolsTest.php:415: '@deprecated match on second field, * for first' => [
sysext/core/Tests/Unit/Configuration/FlexForm/FlexFormToolsTest.php:477: '@deprecated chain falls through with no match on first value to *' => [
sysext/core/Classes/Cache/CacheFactory.php:24: * @deprecated This file is not in use anymore, as the functionality
sysext/core/Classes/Cache/CacheFactory.php:51: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9, as it is not needed anymore
sysext/core/Classes/Html/RteHtmlParser.php:199: // @deprecated since TYPO3 v8, will be removed in TYPO3 v9 - the else{} part can be removed in v9
sysext/core/Classes/Html/RteHtmlParser.php:296: // @deprecated since TYPO3 v8, will be removed in TYPO3 v9 - NEXT line can be removed in v9
sysext/core/Classes/Imaging/IconRegistry.php:3298: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9
sysext/core/Classes/Imaging/GraphicalFunctions.php:216: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9
sysext/core/Classes/Imaging/GraphicalFunctions.php:1928: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9 - use GeneralUtility::getFileAbsFileName()
sysext/core/Classes/Imaging/GraphicalFunctions.php:2659: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9, use GeneralUtility::mkdir_deep() directly.
sysext/core/Classes/Resource/Utility/BackendUtility.php:32: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9
sysext/core/Classes/Core/Bootstrap.php:440: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9. Use the Install Tool to dump autoload information.
sysext/core/Classes/Core/Bootstrap.php:913: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9
sysext/core/Classes/Messaging/FlashMessage.php:34: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9
sysext/core/Classes/Messaging/FlashMessage.php:46: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9
sysext/core/Classes/Messaging/FlashMessage.php:96: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9
sysext/core/Classes/Messaging/FlashMessage.php:108: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9
sysext/core/Classes/Messaging/ErrorpageMessage.php:32: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9, use the ErrorPageController instead
sysext/core/Classes/Messaging/AbstractStandaloneMessage.php:53: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9, use the ErrorPageController instead
sysext/core/Classes/Page/PageRenderer.php:2107: // Note: this method of adding Ajax URLs is @deprecated as of TYPO3 v8, and will be removed in TYPO3 v9
sysext/core/Classes/Database/PreparedStatement.php:21: * @deprecated ------------- THE WHOLE CLASS WILL BE REMOVED IN TYPO3 v9 ---------------------
sysext/core/Classes/Database/PreparedStatement.php:166: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9, use Doctrine DBAL as it does PreparedStatements built-in
sysext/core/Classes/Database/QueryView.php:587: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9
sysext/core/Classes/Database/DatabaseConnection.php:23: * @deprecated ------------- THE WHOLE CLASS WILL BE REMOVED IN TYPO3 v9 ----------------------------------------------
sysext/core/Classes/Database/RelationHandler.php:1253: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9
sysext/core/Classes/TypoScript/TemplateService.php:1312: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9, use TypoScriptService::explodeConfigurationForOptionSplit() instead
sysext/core/Classes/TypoScript/TemplateService.php:1412: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9, use $this->getFileName() and file_get_contents directly
sysext/core/Classes/TypoScript/TemplateService.php:1430: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9, use rtrim($url, '?') instead
sysext/core/Classes/TypoScript/TemplateService.php:1450: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9, use ArrayUtility::filterAndSortByNumericKeys instead
sysext/core/Classes/Utility/File/ExtendedFileUtility.php:289: * @deprecated since TYPO3 CMS 8, will be removed in TYPO3 CMS 9
sysext/core/Classes/Utility/File/BasicFileUtility.php:126: * @deprecated but still in use in the Core. Don't use in your extensions!
sysext/core/Classes/Utility/File/BasicFileUtility.php:162: * @deprecated but still in use in the Core. Don't use in your extensions!
sysext/core/Classes/Utility/File/BasicFileUtility.php:216: * @deprecated but still in use in the Core. Don't use in your extensions!
sysext/core/Classes/Utility/ArrayUtility.php:653: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9, use in_array instead
sysext/core/Classes/Authentication/AbstractUserAuthentication.php:1142: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9
sysext/core/Classes/Authentication/AbstractUserAuthentication.php:1196: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9
sysext/core/Classes/Localization/LocalizationFactory.php:70: // @deprecated since TYPO3 v8, will be removed with TYPO3 v9
sysext/core/Classes/TimeTracker/NullTimeTracker.php:21: * @deprecated since TYPO3 v8, will be removed in v9
sysext/core/Classes/TimeTracker/NullTimeTracker.php:31: * @deprecated since TYPO3 v8, will be removed in v9, use the regular time tracking
sysext/core/Classes/Controller/CommandLineController.php:21: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9, use a custom Command instead
sysext/core/Classes/Controller/CommandLineController.php:63: * @deprecated the CommandLineController is deprecated since TYPO3 v8 and will be removed in TYPO3 v9, use a separate CLI Command instead
sysext/core/Classes/Configuration/FlexForm/FlexFormTools.php:495: // @deprecated since TYPO3 v8, will be removed in TYPO3 v9 - just remove this elseif together with two unit tests
sysext/core/Classes/Http/AjaxRequestHandler.php:23: * @deprecated since TYPO3 v8, will be removed in TYPO3 v9
sysext/core/Configuration/DefaultConfigurationDescription.php:148: 'maxSessionDataSize' => 'Integer: Setting (deprecated) the maximum size (bytes) of frontend session data stored in the table fe_session_data. Set to zero (0) means no limit, but this is not recommended since it also disables a check that session data is stored only if a confirmed cookie is set. @deprecated since TYPO3 v8, will be removed in TYPO3 v9.',

Associated revisions

Revision d0f87bf9 (diff)
Added by Christian Kuhn over 2 years ago

[!!!][TASK] Remove deprecated code from ext:core

Resolves: #80716
Releases: master
Change-Id: Ia6b8cecc7527b168be2d35cbae28009d6626c8d8
Reviewed-on: https://review.typo3.org/52517
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision 83a1d676 (diff)
Added by Georg Ringer over 2 years ago

[FOLLOWUP][!!!][TASK] Remove deprecated code from ext:core

Read lines which are actually needed, e.g. to show
the settings in the Extension Manager.

Resolves: #80716
Releases: master
Change-Id: Ie87f91a1f7443d9365e4313b5ea4707e4bd1e50b
Reviewed-on: https://review.typo3.org/52575
Tested-by: TYPO3com <>
Reviewed-by: Jan Helke <>
Tested-by: Jan Helke <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Christian Kuhn over 2 years ago

  • Assignee set to Christian Kuhn

#2 Updated by Gerrit Code Review over 2 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52517

#3 Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52517

#4 Updated by Gerrit Code Review over 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52517

#5 Updated by Gerrit Code Review over 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52517

#6 Updated by Gerrit Code Review over 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52517

#7 Updated by Gerrit Code Review over 2 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52517

#8 Updated by Gerrit Code Review over 2 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52517

#9 Updated by Gerrit Code Review over 2 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52517

#10 Updated by Gerrit Code Review over 2 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52517

#11 Updated by Gerrit Code Review over 2 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52517

#12 Updated by Gerrit Code Review over 2 years ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52517

#13 Updated by Christian Kuhn over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#14 Updated by Gerrit Code Review over 2 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52575

#15 Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52575

#16 Updated by Gerrit Code Review over 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52575

#17 Updated by Georg Ringer over 2 years ago

  • Status changed from Under Review to Resolved

#18 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF