Project

General

Profile

Actions

Bug #80780

closed

Incomplete query when "Show database queries performed" selected

Added by Christian Toffolo almost 7 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2017-04-10
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In Upgrade wizard when the option "Show database queries performed" is selected then often the query is displayed like
UPDATE `sys_be_shortcuts` SET `url` = :dcValue1 WHERE `uid` = :dcValue2

An admin want to automate the query in multiple TYPO3 installations but can't know what really happened since he can't know what ':dcValueX' is.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #84632: Upgrade wizards do not show executed SQL statementsRejected2018-04-05

Actions
Actions #1

Updated by Benni Mack almost 7 years ago

  • Target version changed from 8 LTS to next-patchlevel
Actions #2

Updated by Sybille Peters almost 6 years ago

  • Related to Bug #84632: Upgrade wizards do not show executed SQL statements added
Actions #3

Updated by Christian Kuhn over 5 years ago

  • Status changed from New to Rejected

Hey. The feature has always been done half-way since ever and it got worse with doctrine since v8. In v9, the feature has been removed. Since v8 (?) wizards are also marked in db as done and not in LocalConfiguration anymore, so it is much easier now to re-run them after deployment. Since v9, that's even possible via cli. Thus, there shouldn't be any need to copy+paste the queries around anymore - just re-run the wizard. I'll reject the issue for now.

Actions

Also available in: Atom PDF