Bug #80807

Upgrade Wizard / Execute database migrations on single rows / Error: The RecordLinkHandler expects identifier and uid as $parameter configuration

Added by Christian Toffolo almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2017-04-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When I run "Upgrade Wizard / Execute database migrations on single rows" I get this error
"The RecordLinkHandler expects identifier and uid as $parameter configuration"

I debugged and found that the upgrade wizard calls $linkService->resolve($link) that returns

$linkParts = [
    type = "record",
    url = [
        identifier = "tx_ianshop",
        table = "tx_ianshop_domain_model_product",
        uid = "2",
    ]
]

with $link="record:tx_ianshop:tx_ianshop_domain_model_product:2"

then calls $linkService->asString($linkParts)
that calls \TYPO3\CMS\Core\LinkHandling\RecordLinkHandler::asString
that expect an array like

$parameters = [
    identifier = "tx_ianshop",
    uid = "2",
]

instead it receives the array $parameters = $linkParts.


Related issues

Is duplicate of TYPO3 Core - Bug #80806: Upgrade Wizard / Execute database migrations on single rows / Error: The RecordLinkHandler expects identifier and uid as $parameter configurationClosedMarkus Klein2017-04-11

Actions
#1

Updated by Morton Jonuschat almost 4 years ago

  • Is duplicate of Bug #80806: Upgrade Wizard / Execute database migrations on single rows / Error: The RecordLinkHandler expects identifier and uid as $parameter configuration added
#2

Updated by Morton Jonuschat almost 4 years ago

  • Status changed from New to Closed

Duplicate of #80807

Also available in: Atom PDF