Bug #80874

QueryBuilder::quoteIdentifiersForSelect - No subselects possible

Added by Bastian Zagar over 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Start date:
2017-04-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

Hello,

the hardcore quoting in TYPO3\CMS\Core\Database\Query\QueryBuilder of all fields don't allow any subselects (e.g.) when using the hook at

$GLOBALS['TYPO3_CONF_VARS']['SC_OPTIONS']["TYPO3\\CMS\\Recordlist\\RecordList\\DatabaseRecordList"]['buildQueryParameters']
because everything is quoted except the "*".

I am not sure if this is wanted but i am declaring this as a bug because subselects should be possible.


Related issues

Related to TYPO3 Core - Task #81651: Hand over whole querybuilder object into list-modul hookClosedFrank Naegler2017-06-21

Actions
#1

Updated by Bastian Zagar about 4 years ago

Problem is found in

QueryBuilder::quoteIdentifiersForSelect

#2

Updated by Benni Mack about 4 years ago

  • Target version changed from 8 LTS to next-patchlevel
#3

Updated by Julian Mair over 3 years ago

Is it not already possible to do exaclty that with QueryBuilder::selectLiteral and QueryBuilder::addSelectLiteral?

But nevertheless, for the 'FROM' clause it should be possible too ...
btw. even doctrine say, that we are not forced to quote everthing. In many cases they causing more problems than they solve...
@see: https://github.com/doctrine/dbal/blob/2.6/lib/Doctrine/DBAL/Connection.php#L806

#4

Updated by Benni Mack over 2 years ago

  • Target version changed from next-patchlevel to Candidate for patchlevel
#5

Updated by Susanne Moog over 1 year ago

  • Status changed from New to Closed

Fixed with #81651 - the complete $queryBuilder is now available and can be used / adjusted.

#6

Updated by Susanne Moog over 1 year ago

  • Related to Task #81651: Hand over whole querybuilder object into list-modul hook added

Also available in: Atom PDF