Bug #80890

8.7.1 Test setup & Combining images. Images are not generated correctly.

Added by Alexander Averbuch about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2017-04-19
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In the Install tool, the images are not generated or saved correctly.
I'm using GraphicsMagick 1.3.23 2015-11-07.

Command:
'/usr/bin/gm' 'convert' +profile '*' -colorspace GRAY +matte '/var/www/vhosts/typo3eight/typo3/sysext/install/Resources/Public/Images/TestInput/MaskBlackWhite.gif[0]' 'typo3temp/var/transient/a65fcdc2262700c611a514ee1b96e4de.gif'
Command:
'/usr/bin/gm' 'composite' +profile '*' -compose over +matte '/var/www/vhosts/typo3eight/typo3/sysext/install/Resources/Public/Images/TestInput/Test.jpg' '/var/www/vhosts/typo3eight/typo3/sysext/install/Resources/Public/Images/TestInput/BackgroundOrange.gif' 'typo3temp/var/transient/a65fcdc2262700c611a514ee1b96e4de.gif' 'typo3temp/assets/images/installTool-typo3InstallTestcombine158f733c6a2baf151144910.jpg'

The path to the generated image looks like this:

http://typo3eight.dev/tallTool-typo3InstallTestcombine258f733c6aa264586131670.jpg?1492595654

typo3-installtool.PNG View (257 KB) Alexander Averbuch, 2017-04-19 11:57


Related issues

Related to TYPO3 Core - Bug #80690: Install-Tool testsetup uses deprecated function tempPath() for combine image and gdlib Closed 2017-04-05

History

#1 Updated by Alex Kellner about 2 years ago

Can confirm this on two different systems.
  • Combining Images and
  • GDlib tests
    are broken

#2 Updated by Christian Kuhn about 2 years ago

  • Related to Bug #80690: Install-Tool testsetup uses deprecated function tempPath() for combine image and gdlib added

#3 Updated by Christian Kuhn about 2 years ago

  • Status changed from New to Resolved

has been fixed with #80690 - would be cool if you could retest master or 8.7 branch.

#4 Updated by Alexander Averbuch about 2 years ago

yes, it works in the branch TYPO3_8-7

#5 Updated by Robin Kreide over 1 year ago

  • Priority changed from Must have to Could have

(First of all: I’m a newbie to the TYPO3 issue tracker. So I hope, editing a resolved issue is the correct procedure. If I should have opened a new issue instead please tell me so. Advice welcome!!!)

In my local installations of TYPO 8.7.7 (Ubuntu 16.04) all image processing tests done by the installer fail to show any images/graphics. Neither the original nor the processed files are shown since the AJAX-Requests that fetch the images fail.

The processed files are written to /typo3temp/assets/images/, so the processing works. The AJAX-Request then has to look under localhost/myproject//htdocs/typo3temp/assets/images/. It seems, however, that it looks under localhost/typo3temp/assets/images/. “myproject/htdocs” is missing.

Problem solved: The Reason was a wrongly configured DocumentRoot. It pointed to /var/www/ instead of /var/www/project/web/. The configuration /var/www/ worked on <8 branches of typo3.

#6 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF