Project

General

Profile

Actions

Bug #80966

closed

RTE CKEditor: iFrame in Link Browser PopUp too small (Safari)

Added by Benjamin Robinson about 7 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2017-04-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In Safari (v 10.1) the iframe for selecting a link-target has a height of only 150px and is much smaller than the popup itself.
I have attached a screenshot.
TYPO3-Version: 8.7.1


Files

screenshot.png (23.6 KB) screenshot.png Benjamin Robinson, 2017-04-22 19:14

Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #81539: Correct overflow behavior for iframes in modal windowsClosed2017-06-11

Actions
Actions #1

Updated by Riccardo De Contardi about 7 years ago

that seems a problem of Safari with Iframes. I was able to fix it adding to its parent ( .modal-type-iframe .modal-body):

position:absolute;
width:100%;
height:100%;

I have not yet tested the effect on other browsers

Actions #2

Updated by Benni Mack about 7 years ago

  • Target version changed from 8 LTS to next-patchlevel
Actions #3

Updated by Frank Rakow about 7 years ago

Same issue in Chrome 59
.modal-iframe needs

position: absolute;

Actions #4

Updated by Riccardo De Contardi about 7 years ago

No more reproducible on latest master (I think it has been solved with https://review.typo3.org/#/c/53184/ that should be soon backported to 8.7, too)

Actions #5

Updated by Mona Muzaffar almost 7 years ago

  • Is duplicate of Bug #81539: Correct overflow behavior for iframes in modal windows added
Actions #6

Updated by Mona Muzaffar almost 7 years ago

  • Status changed from New to Resolved

Closing this issue as resolved.
The patch Riccardo mentioned has already been backported - see https://review.typo3.org/#/c/53203.
(https://forge.typo3.org/issues/81539#note-3)

If you think that this is the wrong decision or experience this issue again, please reopen this ticket or open a new ticket and add a relation to this ticket number.

Actions #7

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF