Project

General

Profile

Actions

Bug #81056

closed

Query Builder fails on greater / less comparisons on string fields

Added by Matthias Krappitz almost 7 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extbase
Target version:
Start date:
2017-04-28
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I upgraded a TYPO3 7.6.18 system to 8.7.1 and now in an extbase repository class in a custom finder method if i do this, i get results:

$query = $this->createQuery();
$result = $query
    ->matching(
        $query->like('quote', '%It was a pleasure%')
    )
    ->execute();

Whereas if i do this, i get no results:

$query = $this->createQuery();
$result = $query
    ->matching(
        $query->greaterThan('quote', '')
    )
    ->execute();

Even though there obviously do exist records with field "quote" being non empty as proven by the first query. With TYPO3 CMS 7.6.18 the $query->greaterThan('quote', '') comparison worked fine on the same data / system, returnin results. I guess there is internal problem in v8 with forming this query / comparison in the doctrine query builder.


Related issues 2 (1 open1 closed)

Related to TYPO3 Core - Bug #79473: Typo3DbQueryParser fails since Doctrine by comparing date fieldsNew2017-01-26

Actions
Related to TYPO3 Core - Bug #81487: Quoting error for date field when building query in extbase repositoryClosed2017-06-06

Actions
Actions #1

Updated by Riccardo De Contardi almost 7 years ago

  • Related to Bug #79473: Typo3DbQueryParser fails since Doctrine by comparing date fields added
Actions #2

Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52802

Actions #3

Updated by Morton Jonuschat over 6 years ago

  • Related to Bug #81487: Quoting error for date field when building query in extbase repository added
Actions #4

Updated by Gerrit Code Review over 6 years ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52802

Actions #5

Updated by Gerrit Code Review over 6 years ago

Patch set 12 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52802

Actions #6

Updated by Gerrit Code Review over 6 years ago

Patch set 13 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52802

Actions #7

Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53244

Actions #8

Updated by Christian Toffolo over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #9

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF