Bug #81126

After $querySettings()->setLanguageUid(1); it doesn't change.

Added by Bharat parmar about 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extbase + l10n
Target version:
-
Start date:
2017-05-03
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I have one method in my repository findByUidWithLangId($uid,$lang=0) in this i set $querySettings()->setLanguageUid(1); untill this works fine and give me record with $uid in L=1.

But after this when i call default Repository method findByUid($uid) on same repository ,it give me record with L=1 but it should gives me record in default language.

Problem is that setLanguageUid(1) is once set is remain persist even though i try to reset it to 0.


Related issues

Is duplicate of TYPO3 Core - Bug #59992: Persistence session doesn't take overlays into accountAccepted2014-06-30

Actions
#1

Updated by Steffen Gebert about 4 years ago

  • Project changed from forge.typo3.org to TYPO3 Core
  • Category deleted (Development)
  • TYPO3 Version set to 9
#2

Updated by Susanne Moog over 3 years ago

  • Category set to Extbase + l10n
#3

Updated by Tymoteusz Motylewski over 2 years ago

  • Status changed from New to Closed

I'm closing it as a duplicate of https://forge.typo3.org/issues/59992

#4

Updated by Tymoteusz Motylewski over 2 years ago

  • Is duplicate of Bug #59992: Persistence session doesn't take overlays into account added

Also available in: Atom PDF