Bug #81228

Epic #77562: Misbehaviors with datetime values and timezones

l10n_mode exclude doesn't work correctly for timestamp fields

Added by Markus no-lastname-given almost 4 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-05-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In TYPO3 8.7.1 I have the following TCA:

'date' => [
'exclude' => true,
'l10n_mode' => 'exclude',
'l10n_display' => 'defaultAsReadonly',
'label' => 'Date',
'config' => [
'type' => 'input',
'eval' => 'date',
'disableAgeDisplay' => 1,
'default' => time()
],
],

The system is set to German as default and English as secondary language.

Now when I edit the record in TYPO3 backend and save the date in German, it is correctly set for the English record as well - BUT when I edit the English record (where I can't set the date, because the field is set to "defaultAsReadonly"), the date for the English record is changed to one day before after/on save. The German Record remains unchanged. The behaviour doesn't seem to be connected to the l10n_display setting; if it is ommited, the field is not displayed, but nevertheless changed on save.

#1

Updated by Mona Muzaffar almost 4 years ago

  • Related to Epic #80852: Datetime handling in backend added
#2

Updated by Markus no-lastname-given almost 4 years ago

The problem is fixed for me; I had a wrong locale setting in my setup:

[globalVar = GP:L = 1]
# Wrong
#  config.locale_all = en_US.utf-8

# Correct
config.locale_all = en_US.utf8
[END]

I still think the behaviour is a bit odd, but with the right settings, the date is handled correctly.

#3

Updated by Riccardo De Contardi over 3 years ago

  • Parent task set to #77562
#4

Updated by Riccardo De Contardi over 3 years ago

  • Related to deleted (Epic #80852: Datetime handling in backend)
#5

Updated by Riccardo De Contardi about 3 years ago

  • Status changed from New to Needs Feedback

Is there something missing or is there still work to do, or can we close this one? Thank you!

#6

Updated by Alexander Opitz almost 3 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

#7

Updated by ondro no-lastname-given 7 months ago

Just for the info: we had a same problem as described here but for typo3 version 9.5
The problem was in php setting of timezone. When we changed following setting of typo3, it solves the problem

$GLOBALS['TYPO3_CONF_VARS']['SYS']['phpTimeZone'] = 'UTC';

Also available in: Atom PDF