Bug #81384

Form plugin crashs when using layout or partial paths

Added by Felix Nagel over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Category:
Form Framework
Target version:
-
Start date:
2017-05-30
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When using templatePathAndFilename with partial and / or layout paths config like this:

templatePathAndFilename: 'EXT:my_ext/Resources/Private/Form/Templates/Finishers/Email/{@format}.html'
layoutRootPaths:
 100: 'EXT:my_ext/Resources/Private/Layouts/'
partialRootPaths:
 100: 'EXT:my_ext/Resources/Private/Partials/'

the form plugin will crash with following error when opened:

Return value of TYPO3\CMS\Form\Hooks\DataStructureIdentifierHook::extractDottedPathToLastElement() must be of the type string, integer returned 

Related issues

Is duplicate of TYPO3 Core - Bug #80919: Form CE runs into TypeError when a number is used as option key for a finisherClosedDaniel Goerz2017-04-20

Actions
#1

Updated by Ralf Zimmermann over 4 years ago

  • Related to Bug #80974: Form Email finisher doesn't support templateRootPaths added
#2

Updated by Ralf Zimmermann over 4 years ago

  • Assignee set to Ralf Zimmermann
#3

Updated by Ralf Zimmermann over 4 years ago

  • Is duplicate of Bug #80919: Form CE runs into TypeError when a number is used as option key for a finisher added
#4

Updated by Ralf Zimmermann over 4 years ago

  • Related to deleted (Bug #80974: Form Email finisher doesn't support templateRootPaths)
#5

Updated by Ralf Zimmermann over 4 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Already fixed by #80919

Also available in: Atom PDF