Bug #80974

Form Email finisher doesn't support templateRootPaths

Added by Frans Saris about 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Form Framework
Target version:
-
Start date:
2017-04-24
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The EmailFinisher uses templatePathAndFilename and due to this it doesn't support the fallback we know from most places in the core (templateRootPaths).

My suggestion would be:

instead of

   templatePathAndFilename: 'EXT:form/Resources/Private/Frontend/Templates/Finishers/Email/{@format}.html'

use

   templateName: '{@format}.html'
   templateRootPaths.20 = 'EXT:form/Resources/Private/Frontend/Templates/Finishers/Email/'

#1

Updated by Ralf Zimmermann almost 4 years ago

  • Related to Bug #81384: Form plugin crashs when using layout or partial paths added
#2

Updated by Ralf Zimmermann almost 4 years ago

  • Assignee set to Ralf Zimmermann
#3

Updated by Ralf Zimmermann almost 4 years ago

  • Related to deleted (Bug #81384: Form plugin crashs when using layout or partial paths)
#4

Updated by Ralf Zimmermann almost 4 years ago

  • Tracker changed from Bug to Feature
#5

Updated by Gerrit Code Review almost 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53365

#6

Updated by Frans Saris almost 4 years ago

IMO this is a bug and not a feature because this behavior is inconsistent with the rest of the core

#7

Updated by Bjoern Jacob almost 4 years ago

  • Tracker changed from Feature to Bug
  • TYPO3 Version set to 8

Okay, fine with me :)

#8

Updated by Gerrit Code Review almost 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53365

#9

Updated by Gerrit Code Review almost 4 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53692

#10

Updated by Ralf Zimmermann almost 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#11

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF