Bug #81479

Toolbar hides icons if there are too many Pagetypes

Added by Felix König about 1 year ago. Updated 8 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2017-06-06
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
toolbar, x-toolbar, doktype, pagetype
Complexity:
medium
Is Regression:
Sprint Focus:

Description

Hey,

when there are too many pagetypes (added manually), the icons for these pagetypes are unscrollable hidden at the right border.

Setting the css to overflow: auto; solves the problem.
Also affects TYPO3 7.x.


Related issues

Related to TYPO3 Core - Bug #80056: Pagetree Toolbar Drag&Drop: Overflow if you have more then 11 Page-Types Closed 2017-02-28

Associated revisions

Revision 50909aae (diff)
Added by Felix König 8 months ago

[BUGFIX] Make Toolbar scrollable if there are too many Pagetypes

If there are too many Pagetype icons for the viewport,
the toolbar is scrollable

Resolves: #81479
Releases: 8.7
Change-Id: Ie46c96a01935750d3e7313006b31a8b31d25e5e8
Reviewed-on: https://review.typo3.org/54996
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

History

#1 Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53136

#2 Updated by Riccardo De Contardi about 1 year ago

  • Related to Bug #80056: Pagetree Toolbar Drag&Drop: Overflow if you have more then 11 Page-Types added

#3 Updated by Riccardo De Contardi about 1 year ago

I think it is a duplicate of this one: #80056

#4 Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53136

#5 Updated by Gerrit Code Review about 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53136

#6 Updated by Susanne Moog about 1 year ago

  • Complexity set to medium
  • Sprint Focus set to On Location Sprint

#7 Updated by Anja Leichsenring 12 months ago

  • Sprint Focus deleted (On Location Sprint)

#8 Updated by Gerrit Code Review 8 months ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54996

#9 Updated by Felix König 8 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF