Project

General

Profile

Actions

Bug #81637

closed

Error when saving a forms Plugin

Added by Markus Klein over 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
DataHandler aka TCEmain
Target version:
Start date:
2017-06-20
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

When saving a content element with plugin Forms I get an error: In TYPO 8.7.1. there was no error, but on TYPO3 8.7.2:

Oops, an error occurred!
Argument 2 passed to TYPO3\CMS\Core\Database\ReferenceIndex::getRecordRawCached() must be of the type integer, null given, called in /home/wim/typo3_src-8.7.2/typo3/sysext/core/Classes/Database/ReferenceIndex.php on line 240

Reported via mailinglist.


Files


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #78634: Reference index causes an order of magnitude more SQL requests than necessaryClosed2016-11-10

Actions
Actions #1

Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53293

Actions #2

Updated by Markus Klein over 6 years ago

  • Related to Bug #78634: Reference index causes an order of magnitude more SQL requests than necessary added
Actions #3

Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53293

Actions #4

Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53293

Actions #5

Updated by Gerrit Code Review over 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53293

Actions #7

Updated by Wim Spijker over 6 years ago

Maskus Klein asked me to give information about this bug. This is my first entry, I hope all went well

This happens when opening content element to view or change, then save that gives this error. The changed text has been saved (you must refresh site). I have a 3 language site, default NL, language 1 EN and language 2 DE

Oops, an error occurred!
Argument 2 passed to TYPO3\CMS\Core\Database\ReferenceIndex::getRecordRawCached() must be of the type integer, null given, called in /home/wim/typo3_src-8.7.2/typo3/sysext/core/Classes/Database/ReferenceIndex.php on line 240

My system:
TYPO3 version 8.7.2
UBUNTU 16.04 server
PHP 7.0.18
MySQL 5.7.18

best regards
Wim

It also happens if you have a text/media content element and you delete de image. After refreshing: the image is NOT deleted. Adding an image is also not possible.
It also happens when you unhide a content element.
At the moment my TYPO3 site is not usable, can I safely go back to 8.7.1?

Actions #8

Updated by Christian Toffolo over 6 years ago

Same problem here. It looks like a gridelements problem with TYPO3 8.7.2 here:
https://github.com/TYPO3-extensions/gridelements/blob/master/Classes/DataHandler/AbstractDataHandler.php#L247
$updateArray['tx_gridelements_container'] is NULL when hide/unhide CE in a translated page.

Actions #9

Updated by Christian Kuhn over 6 years ago

how to reproduce (tested 8.7):
  • have gridelements latest installed
  • create page
  • create content element text+image on page, have an image assigned
  • create alternative page language
  • use "translate" button in page module for column with text+image element, "translate" (not copy) -> error in last step
Actions #10

Updated by Michael Binder over 6 years ago

I've had this issue too. The Problem comes with gridelements (not supported for TYPO3 8).

The patch worked for me. After the patch was installed I could again create translations and save the plugin elements.

Tested with:
  • TYPO3 8.7.2
  • Gridelements 7.1.0
Actions #11

Updated by Markus Klein over 6 years ago

gridelements 7.1 is not compatible with v8, you need to use the latest version from git (master branch).

In general the bug is present and might be triggered also in other cases, not only gridelements, as Christian's comment shows.

Currently there is a bigger evaluation, whether the original patch might be reverted or modified and if the current solution is still needed then or not.

Actions #12

Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53378

Actions #13

Updated by Markus Klein over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #15

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF