Bug #81747

Copying workspace version record fails

Added by Oliver Hader over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
DataHandler aka TCEmain
Target version:
Start date:
2017-06-29
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Copying workspace version records fails in Doctrine DBAL exception due to using computed properties directly in the database - which do not exist. This misbehavior has been introduced in issue #79515 which switched to use BackendUtility:workspaceOL() without further sanitization.

Example of Doctrine DBAL exception:

Doctrine\DBAL\Exception\InvalidFieldNameException: An exception occurred while executing 'SELECT `uid`, `pid`, `t3ver_oid`, `t3ver_id`, `t3ver_wsid`, `t3ver_label`, `t3ver_state`, `t3ver_stage`, `t3ver_count`, `t3ver_tstamp`, `t3ver_move_id`, `t3_origuid`, `tstamp`, `crdate`, `cruser_id`, `editlock`, `hidden`, `sorting`, `CType`, `header`, `header_position`, `rowDescription`, `bodytext`, `bullets_type`, `uploads_description`, `uploads_type`, `assets`, `image`, `imagewidth`, `imageorient`, `imagecols`, `imageborder`, `media`, `layout`, `frame_class`, `deleted`, `cols`, `spaceBefore`, `spaceAfter`, `space_before_class`, `space_after_class`, `records`, `pages`, `starttime`, `endtime`, `colPos`, `subheader`, `fe_group`, `header_link`, `image_zoom`, `header_layout`, `list_type`, `sectionIndex`, `linkToTop`, `file_collections`, `filelink_size`, `filelink_sorting`, `target`, `date`, `recursive`, `imageheight`, `sys_language_uid`, `pi_flexform`, `accessibility_title`, `accessibility_bypass`, `accessibility_bypass_text`, `l18n_parent`, `l18n_diffsource`, `l10n_source`, `selected_categories`, `category_field`, `table_class`, `table_caption`, `table_delimiter`, `table_enclosure`, `table_header_position`, `table_tfoot`, `tx_irretutorial_1nff_hotels`, `tx_irretutorial_1ncsv_hotels`, `tx_irretutorial_flexform`, `l10n_state`, `categories`, `_ORIG_pid` FROM `tt_content` WHERE (`pid` = ?) AND (`t3ver_oid` = ?) AND (`t3ver_wsid` = ?) AND (`tt_content`.`deleted` = 0)' with params [-1, 300, 1]:


Related issues

Related to TYPO3 Core - Task #79515: Wrap doesRecordExist in new method Closed 2017-01-27

Associated revisions

Revision dbe425f9 (diff)
Added by Oliver Hader over 2 years ago

[BUGFIX] Copying workspace version record fails

Copying workspace version records fails in Doctrine DBAL exception due to
using computed properties directly in the database - which do not exist.
This misbehavior has been introduced in issue #79515 which switched to
use BackendUtility:workspaceOL() without further sanitization.

Resolves: #81747
Releases: master, 8.7
Change-Id: Iabc67f9a7375d4246289e50205aac6dc8c750259
Reviewed-on: https://review.typo3.org/53357
Reviewed-by: Markus Klein <>
Tested-by: TYPO3com <>
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

Revision c162474a (diff)
Added by Oliver Hader over 2 years ago

[BUGFIX] Copying workspace version record fails

Copying workspace version records fails in Doctrine DBAL exception due to
using computed properties directly in the database - which do not exist.
This misbehavior has been introduced in issue #79515 which switched to
use BackendUtility:workspaceOL() without further sanitization.

Resolves: #81747
Releases: master, 8.7
Change-Id: Iabc67f9a7375d4246289e50205aac6dc8c750259
Reviewed-on: https://review.typo3.org/53357
Reviewed-by: Markus Klein <markus.klein@typo3.org>
Tested-by: TYPO3com <no-reply@typo3.com>
Reviewed-by: Oliver Hader <oliver.hader@typo3.org>
Tested-by: Oliver Hader <oliver.hader@typo3.org>
Reviewed-on: https://review.typo3.org/53371

History

#1 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53357

#2 Updated by Oliver Hader over 2 years ago

  • Related to Task #79515: Wrap doesRecordExist in new method added

#3 Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53357

#4 Updated by Gerrit Code Review over 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53357

#5 Updated by Gerrit Code Review over 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53357

#6 Updated by Gerrit Code Review over 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53357

#7 Updated by Markus Klein over 2 years ago

  • Priority changed from Should have to Must have
  • Target version set to next-patchlevel

#8 Updated by Gerrit Code Review over 2 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53357

#9 Updated by Gerrit Code Review over 2 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53357

#10 Updated by Oliver Hader over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#11 Updated by Gerrit Code Review over 2 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53371

#12 Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53371

#13 Updated by Oliver Hader over 2 years ago

  • Status changed from Under Review to Resolved

#14 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF