Bug #82047

Files are not considered for page tree export to .T3D

Added by Christian Müller about 1 year ago. Updated 9 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Import/Export (T3D)
Target version:
Start date:
2017-08-04
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
t3d,import,export,fal,file,files,impexp
Complexity:
Is Regression:
Sprint Focus:

Description

I tried to export a page tree in several 7.6 systems (starting from the root page e.g. pid 1). Every table was selected.
Even the option "Save files in extra folder beside the export file: (supported for "Save to filename" only)" creates an empty folder for the files.


Related issues

Related to TYPO3 Core - Task #49227: Files missing in import/export Closed 2013-06-18

History

#1 Updated by Christian Müller about 1 year ago

  • Related to Task #49227: Files missing in import/export added

#2 Updated by Christian Müller about 1 year ago

  • Description updated (diff)

#3 Updated by Sven Burkert 9 months ago

  • Description updated (diff)
  • Tags changed from t3d,import,export,fal,file,files to t3d,import,export,fal,file,files,impexp

I also have this problem, but with export in TYPO3 8.7 and TYPO3 6.2

#4 Updated by Sven Burkert 9 months ago

  • TYPO3 Version changed from 7 to 8

#5 Updated by Christian Kuhn 9 months ago

  • Status changed from New to Closed

Exporting files and having them in .xml / .t3d / .files folder does work - at least in v8 and v9 (and i guess in v7, too since not much changed codewise in this area, but I did not specifically test this): I just played around with that for a while for the ext:introduction extension.
Make sure you enable the sys_file* tables in "Include relations to tables:" and do NOT include them in "Use static relations for tables:", also do NOT use [All tables] for this one.
This way i was properly able to have fal files from tt_content and other tables in my export - there is a uid shift on import again, but that is a different topic.
I'll close the issue for now. If you still think this is broken, please reopen / create a new issue with more detailed export configuration details, maybe even by submitting a preset dump.

#6 Updated by Sven Burkert 9 months ago

Thank you for helping me with this!
You are right, when setting the export options like you described, the export contains the image files. Tested in TYPO3 8.7 and 6.2.
This seems not very logical to me and should be fixed.

Also available in: Atom PDF