Task #49227

Epic #55070: Workpackages

Epic #54542: WP: Importer / Exporter with relations MM/IRRE/FAL

Story #55520: As an User I want to create exports in v. 6.2 and import them in v. 6.2

Files missing in import/export

Added by Francois Suter about 8 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Category:
Import/Export (T3D)
Target version:
Start date:
2013-06-18
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
7.0
Tags:
Complexity:
hard
Sprint Focus:

Description

When exporting and importing sys_file records using the impexp module, the files are not copied, causing errors after import.

More generally the import/export process works pretty badly with FAL, because all storages and sys_files are stored in pid = 0, making it impossible to export just a few pages with their images. You are obliged to export the whole root.


Related issues

Related to TYPO3 Core - Task #55431: Impexp: file contents of sys_file are not included in exportClosedMarc Bastian Heinrichs2014-01-29

Actions
Related to TYPO3 Core - Task #55532: Impexp: import the binary files being sys_file records to the right storageClosedMarc Bastian Heinrichs2014-01-31

Actions
Related to TYPO3 Core - Bug #72207: Files missing in import/exportClosed2015-12-14

Actions
Related to TYPO3 Core - Task #58693: Ignore sys_file_reference records pointing to missing files on importClosedMarc Bastian Heinrichs2014-05-10

Actions
Related to TYPO3 Core - Bug #82047: Files are not considered for page tree export to .T3DClosed2017-08-04

Actions
Is duplicate of TYPO3 Core - Bug #46679: impexp: Import in v6 fails with fal-errorClosed2013-03-26

Actions
#1

Updated by Marc Bastian Heinrichs over 7 years ago

  • Category changed from File Abstraction Layer (FAL) to Import/Export (T3D)
  • Assignee set to Marc Bastian Heinrichs
  • Target version set to 6.2.0
  • Parent task set to #55520
  • Is Regression set to No
#2

Updated by Marc Bastian Heinrichs over 7 years ago

Hey Francois,

More generally the import/export process works pretty badly with FAL, because all storages and
sys_files are stored in pid = 0, making it impossible to export just a few pages with their
images. You are obliged to export the whole root.

you could include relations stored outside your export tree (also to sys_file records) by selecting the tables in "Include relations to tables:"

#3

Updated by Marc Bastian Heinrichs about 7 years ago

  • Status changed from New to Needs Feedback
  • Assignee changed from Marc Bastian Heinrichs to Francois Suter

Works for you now in 6.2?

#4

Updated by Alexander Opitz almost 7 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

#5

Updated by Francois Suter almost 7 years ago

Sounds fine closing it. I haven't tried such a scenario recently, I know a lot happened in 6.2 in this regard.

#6

Updated by Prakash A Bhat over 5 years ago

I tested this on a 6.2.15 setup.

We had 3 existing domains, we had to do a 4th domain, add content and do a t3d export of the branch.

Well, without any error message about the missing FAL images, Typo3 did do the import/export!

At the other end, the references to sys_file was all wrong.

On analyzing deeper, I see that during the process, the uid_local in "sys_file_reference" did not get updated, instead it tried to use the same value as in the source. Instead this should have used the latest "uid" of the sys_file on the destination.

#7

Updated by Anja Leichsenring over 5 years ago

  • % Done changed from 0 to 100
#8

Updated by Anja Leichsenring over 5 years ago

  • Sprint Focus set to On Location Sprint
#9

Updated by Mathias Schreiber about 5 years ago

  • Sprint Focus deleted (On Location Sprint)
#10

Updated by Bernhard Eckl over 4 years ago

  • TYPO3 Version changed from 6.1 to 7
  • PHP Version changed from 5.3 to 7.0

It is still not possible to import files. I have an 4.6 installatioin here, I wanted to export it and import it in a 7.6 installation -> no images. So I upgraded the 4.6 system to 7.6. But export 7.6 and import to 7.6 -> no images.

No file found for given UID.

Please reopen!

#11

Updated by Christian Müller about 4 years ago

  • % Done changed from 100 to 0
#12

Updated by Christian Müller about 4 years ago

  • % Done changed from 0 to 100
#13

Updated by Christian Müller about 4 years ago

  • Related to Bug #82047: Files are not considered for page tree export to .T3D added
#14

Updated by Christian Kuhn over 3 years ago

Exporting (FAL) files works. i fiddled with ext:introduction recently and had to do this various times now in v8 and v9:

It depends on correct export configuration:
Usually, you do not want to select the sys_file* tables in "Include tables:", but instead select them in "Include relations to tables:", and DO NOT select them in "Use static relations for tables:". With this configuration, files related to for instance tt_content elements are exported, but only those, and not other files which are not connected to your main "Include tables".

Note: ext:introduction now comes with a well configured export preset in https://github.com/FriendsOfTYPO3/introduction/blob/master/Resources/Private/ImportExportPreset.sql - just import that row into DB and play around with the preset a bit.

#15

Updated by Francois Suter over 3 years ago

That's good to know. Thanks for the update.

Also available in: Atom PDF