Bug #82064

indexed search advance option disappear after search result

Added by Jimit Shah 12 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2017-08-09
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.1
Tags:
typo3 , indexed_search
Complexity:
Is Regression:
Sprint Focus:

Description

I am facing one of strange issue in new extBase indexed_search.

When we press the advance search button , indexed_search form shows all the advance option , from where we can select condition and indexed_search works based on selected condition.

but when we get the search result , advance options disappear in new extBase indexed_search.

here is video tutorial : https://www.screencast.com/t/D0QENmDUtU

TYPO3 : 8.7.4
Indexed Search : 8.7.4
PHP : 7.1

Please help me out !

Thanks :)


Related issues

Related to TYPO3 Core - Bug #84995: Indexed search some advanced search fields are never shown Resolved 2018-05-14

Associated revisions

Revision 8e6aa670 (diff)
Added by Peter Niederlag 2 months ago

[BUGFIX] Keep state of extendedSearch

formAction has set a bunch of variables that are required by
the frontend for the extendedSearch

Inside searchAction this parameters were not set resulting in
the extendedSearch section being empty in frontend after searching.

With this change the processing of the variables is extracted
into a method and called from formAction and searchAction.

Releases: master, 8.7
Resolves: #82064
Change-Id: Ia21c445ef0aa72e8e084e9bd021bc5caa7a1e74b
Reviewed-on: https://review.typo3.org/55547
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision b582e126 (diff)
Added by Peter Niederlag 2 months ago

[BUGFIX] Keep state of extendedSearch

formAction has set a bunch of variables that are required by
the frontend for the extendedSearch

Inside searchAction this parameters were not set resulting in
the extendedSearch section being empty in frontend after searching.

With this change the processing of the variables is extracted
into a method and called from formAction and searchAction.

Releases: master, 8.7
Resolves: #82064
Change-Id: Ia21c445ef0aa72e8e084e9bd021bc5caa7a1e74b
Reviewed-on: https://review.typo3.org/54646
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Riccardo De Contardi 11 months ago

  • Category set to Indexed Search

#2 Updated by Peter Niederlag 8 months ago

I can confirm the problem. It's due to some extended search variable being processed and assigned inside the formAction, but not inside searchAction.

#3 Updated by Gerrit Code Review 8 months ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54646

#4 Updated by Gerrit Code Review 6 months ago

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54646

#5 Updated by Gerrit Code Review 6 months ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55547

#6 Updated by Gerrit Code Review 2 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55547

#7 Updated by Gerrit Code Review 2 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55547

#8 Updated by Gerrit Code Review 2 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55547

#9 Updated by Gerrit Code Review 2 months ago

Patch set 3 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54646

#10 Updated by Anonymous 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#11 Updated by Anja Leichsenring 2 months ago

  • Related to Bug #84995: Indexed search some advanced search fields are never shown added

Also available in: Atom PDF