Bug #82294

"$uid must be positive integer, 0 given" if setting content image in metadata to language "all"

Added by Erik Konrad almost 2 years ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2017-09-05
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

We found a bug in TYPO3 8.7.4 core. To reproduce the bug:

- add an image (or image with text) on a page
- save the image
- go to the image tab and push the metadata - pencil
- change language to "all" in metadata
- open the image tab in the content element
- push the metadata pencil a second time

Now it throws the exception "$uid must be positive integer, 0 given". The "more information" helpsite says, that this is a grid element bug, but it isnt. It happens with a fresh TYPO3 installation too.

Error UID=0.PNG View (3.28 KB) Martin Hotmann, 2019-06-11 20:51

Languages.PNG View (2.7 KB) Martin Hotmann, 2019-06-11 20:51


Related issues

Related to TYPO3 Core - Bug #82858: Metadata edit button leads to 'Uncaught Exception' inside Text and Images content element Closed 2017-10-26

History

#1 Updated by Felix Kopp over 1 year ago

We also have this problem in several installations.

#2 Updated by Riccardo De Contardi over 1 year ago

  • Related to Bug #82858: Metadata edit button leads to 'Uncaught Exception' inside Text and Images content element added

#3 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from New to Needs Feedback

Is this a duplicate? #82858

#4 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from Needs Feedback to Closed

Should have been solved with https://review.typo3.org/#/c/54888/ on version 8 and above.

@Felix Kopp: what version did you use? Should be fixed since 8.7.9 - see https://get.typo3.org/release-notes/8.7.9

I close this one for now; please reopen it if you think that this is the wrong decision or experience the issue again and have further information about how to reproduce the issue.

Thank you!

p.s. thanks to Simon Gilli for the hint.

#5 Updated by Martin Hotmann 2 months ago

I encounter exactly this issue!
I cant edit the default language.
Will append a screenshot

I have two languages (german and englisch)

BTW: I'm on TYPO3 9.5.7 and PHP 7.3

#6 Updated by André Markus about 2 months ago

Hi,
I have a great tipp for all of you with this problem.

I think the reason is not a specific TYPO3- oder PHP-Version, its MySQL 5.7 with the Strict Mode!

So here the solution that helped me:
https://serverpilot.io/docs/how-to-disable-strict-mode-in-mysql-5-7

Cheers
André

Also available in: Atom PDF