Bug #82858

Metadata edit button leads to 'Uncaught Exception' inside Text and Images content element

Added by Anu Bhuvanendran Nair over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2017-10-26
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

The workaround is in a multilingual website. Place a 'Text and Images' content element in default language column.
Translate the contents and page using normal localization/translation wizard. While editing the above-mentioned content element in its corresponding translation, move to the tab 'Images'.

On clicking the button for editing metadata, a uncaught exception message kicks in. Seems like a sys_file_metadata record for the respective language and file isn't generated in the sys_file_metadata table. But can't see the need of a button to edit metadata, while metadata can be edited inline.

Please see the screenshots attached.

screenshot-localhost 2017-10-26 17-36-31-873.png View (150 KB) Anu Bhuvanendran Nair, 2017-10-26 14:06

screenshot-localhost 2017-10-26 17-22-37-384.png View (68.7 KB) Anu Bhuvanendran Nair, 2017-10-26 14:06


Related issues

Related to TYPO3 Core - Bug #82294: "$uid must be positive integer, 0 given" if setting content image in metadata to language "all" Closed 2017-09-05

History

#1 Updated by Fedir RYKHTIK over 1 year ago

Hey Anu !
As I could understand, the problem appears only on multilanguage sites ?
On TYPO3 9 master, on basic installation the button is working.
Best regards,
Fedir

#2 Updated by Patrick Broens over 1 year ago

In sys_file_reference there are two ways to edit the title, alternative text and description:

  • In the sys_file_reference itself, so it is only for this reference
  • Clicking the pencil, so you can edit sys_file_metadata, for all references

The error appears when clicking the pencil (to edit sys_file_metadata) in a translated sys_file_reference which does not have a corresponding translated sys_file_metadata. When the sys_file_metadata is translated in the Filelist module, everything is fine and clicking on the button in a translated sys_file_reference is not showing the error anymore.

Or the pencil button to edit the sys_file_metadata should not be in a translated reference if the corresponding translated metadata does not exist, or clicking the pencil should generate the translated metadata if not available.

#3 Updated by Riccardo De Contardi over 1 year ago

  • Related to Bug #82294: "$uid must be positive integer, 0 given" if setting content image in metadata to language "all" added

#4 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from New to Needs Feedback

Hi, Do you think that this could be a possible duplicate of this issue? #82294

Can you add a step-by-step guide on how to reproduce your issue with 8.7.12 or the latest master? I currently find the edit metadata pencil button only in the default language :S

thank you!

#5 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (next-patchlevel)

Should have been solved with https://review.typo3.org/#/c/54888/ on version 8 and above.

I close this one for now; please reopen it if you think that this is the wrong decision or experience the issue again and have further information about how to reproduce the issue.

Thank you!

p.s. thanks to Simon Gilli for the hint.

Also available in: Atom PDF