Bug #82786

Invalid "recordOverview" in form YAML config

Added by Mathias Brodala almost 2 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Form Framework
Target version:
Start date:
2017-10-17
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

The form YAML config uses recordOverview in various locations which must be recordsOverview instead

Associated revisions

Revision e3cf49c9 (diff)
Added by Mathias Brodala almost 2 years ago

[BUGFIX] EXT:form - really disable records overview in redirect finisher

Resolves: #82786
Releases: master, 8.7
Change-Id: I9cdfbcd5e0f25b832ea546f1b8c70a9f544b31aa
Reviewed-on: https://review.typo3.org/54435
Tested-by: TYPO3com <>
Reviewed-by: Stefan Neufeind <>
Tested-by: Stefan Neufeind <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision daec7304 (diff)
Added by Mathias Brodala about 1 year ago

[BUGFIX] EXT:form - really disable records overview in redirect finisher

Resolves: #82786
Releases: master, 8.7
Change-Id: I9cdfbcd5e0f25b832ea546f1b8c70a9f544b31aa
Reviewed-on: https://review.typo3.org/57818
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Gerrit Code Review almost 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54435

#2 Updated by Bjoern Jacob almost 2 years ago

  • Category changed from FormEngine aka TCEforms to Form Framework

#3 Updated by Mathias Brodala almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Ioulia Kondratovitch over 1 year ago

  • Target version changed from next-patchlevel to 8.7.13
  • TYPO3 Version changed from 9 to 8

Mathias Brodala wrote:

Applied in changeset e3cf49c9599f6932569d130d86c4df94948a696d.

The patch/bugfix seems to be included only in TYPO3 >= 9.0.
In TYPO3 8.7.12 we still have an old "recordOverview" which is wrong.
Patch for 8.7.12 needed.

#5 Updated by Mathias Brodala over 1 year ago

  • Target version changed from 8.7.13 to next-patchlevel

You are right, the backport for this one is still missing.

Apparently we don't need the backport, see the last comment in https://review.typo3.org/54435

#6 Updated by Mathias Brodala over 1 year ago

  • TYPO3 Version changed from 8 to 9

#7 Updated by Ioulia Kondratovitch over 1 year ago

Mathias Brodala wrote:

Apparently we don't need the backport, see the last comment in https://review.typo3.org/54435

Hi! I have seen the comment. But in reality we still have the line

                        recordOverview:
                          disabled: 1

in line 70,71 of
.../typo3/sysext/form/Configuration/Yaml/FormEngineSetup.yaml

in TYPO3 8.7.12. Which has no effect due to typo.
If you have a look at the code, you will find it.
I really think this should be fixed.

#8 Updated by Gerrit Code Review about 1 year ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57818

#9 Updated by Mathias Brodala about 1 year ago

  • Status changed from Under Review to Resolved

#10 Updated by Benni Mack 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF