Bug #82962

FrontendUserAuthentication throws PHP error if this->user is not null or not array

Added by Thomas Hohn about 3 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Start date:
2017-11-10
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

It some of out TYPO3 installations we sometime see the following error when a login attempt has failed.

Core: Error handler (FE): PHP Warning: array_merge(): Argument #1 is not an array 
typo3_src/typo3/sysext/frontend/Classes/Authentication/FrontendUserAuthentication.php line 412 

So there might be conditions where $this->user can be something that's not an array or null

#1

Updated by Markus Klein about 3 years ago

IMO $this->user is not null, but a string or something.
The ?? operator would use the false-part of the ternary if it was null.

#2

Updated by Thomas Hohn about 3 years ago

  • Subject changed from FrontendUserAuthentication throws PHP error if this->user is null to FrontendUserAuthentication throws PHP error if this->user is not null or array
  • Description updated (diff)
#3

Updated by Thomas Hohn about 3 years ago

Markus Klein wrote:

IMO $this->user is not null, but a string or something.
The ?? operator would use the false-part of the ternary if it was null.

You are right - my bad - will look into it...

#4

Updated by Thomas Hohn about 3 years ago

  • Subject changed from FrontendUserAuthentication throws PHP error if this->user is not null or array to FrontendUserAuthentication throws PHP error if this->user is not null or not array
#5

Updated by Markus Klein about 3 years ago

Which extensions are part of the game in your case?

#6

Updated by Łukasz Uznański over 2 years ago

How can I reproduce this bug?

#7

Updated by Benni Mack over 1 year ago

  • Target version changed from next-patchlevel to Candidate for patchlevel
#8

Updated by Susanne Moog 8 months ago

  • Status changed from New to Closed

No instructions to reproduce, no feedback since 2 years, closing the issue now - please report back if it happens again.

Also available in: Atom PDF