Bug #82981

FormEngineValidation: range-checks not working for datetime-fields

Added by Stefan Neufeind about 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend JavaScript
Target version:
-
Start date:
2017-11-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

range (lower of upper) are by definition provided as an integer. But the range-check for a datetime-field compares against the text-representation of that date, not against an integer.


Related issues

Related to TYPO3 Core - Bug #81973: FormEngineValidation.parseDate remove fix year 2038ClosedFrank Naegler2017-07-26

Actions
Related to TYPO3 Core - Bug #83240: TCA field with type=input, eval=date with range is broken, always lower range value is applied because of int cast of incoming value before ISO-8601->unix timestamp conversion.Closed2017-12-06

Actions
#1

Updated by Stefan Neufeind about 4 years ago

  • Related to Bug #81973: FormEngineValidation.parseDate remove fix year 2038 added
#2

Updated by Stefan Neufeind about 4 years ago

  • Category set to Backend JavaScript
#3

Updated by Oliver Hader over 3 years ago

  • Status changed from New to Needs Feedback

Is this issue probably fixed already with issue #83240?

#4

Updated by Stefan Neufeind over 3 years ago

  • Status changed from Needs Feedback to Resolved

Yep, tested and works.

#5

Updated by Oliver Hader over 3 years ago

  • Related to Bug #83240: TCA field with type=input, eval=date with range is broken, always lower range value is applied because of int cast of incoming value before ISO-8601->unix timestamp conversion. added
#6

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF