Task #83212

Documentation for impacts with enabled honeypot and site caching

Added by Tobias Pfender over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2017-12-03
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Documentation
Complexity:
Sprint Focus:
Remote Sprint

Description

\TYPO3\CMS\Frontend\Controller\TyposcriptFrontendController->isUserOrGroupSet() checks if $GLOBALS['TSFE']->fe_user->user is an array, but this works only if nowhere in the system, data is stored with TYPO3 session handling.

$GLOBALS['TSFE']->fe_user->setKey();
$GLOBALS['TSFE']->fe_user->storeSessionData();

This stores some "ses_xx" keys in $GLOBALS['TSFE']->fe_user->user array. I'm trying to use EXT:staticfilecache which checks for frontenduser with this method and it returns true on every page, because ext:form stores some data in sessions. I'm pretty sure this is not a bug in EXT:staticfilecache.

I used a clean TYPO3 instance only with sysext, EXT:staticfilecache and a fluidtemplate to debug it.

TYPO3 8.7.8
PHP 7.0


Related issues

Related to TYPO3 Core - Epic #82340: EXT:form - improve documentationNew2017-09-07

Actions

Also available in: Atom PDF