Task #83255

Deprecation notices from ClassSchema.php should contain offending class name

Added by Tymoteusz Motylewski over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Logging
Target version:
-
Start date:
2017-12-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

ClassSchema thows deprecation notices in few places like:

"Tagging methods with @ignorevalidation is deprecated and will be removed ..."

the issue is, that it doesn't give a hint about which file/class contains deprecated code.


Related issues

Related to TYPO3 Core - Epic #82703: Introduce doctrine/annotations to replace user defined annotations (mostly in Extbase)ClosedAlexander Schnitzler2017-10-08

Actions
#1

Updated by Tymoteusz Motylewski over 3 years ago

  • Related to Epic #82703: Introduce doctrine/annotations to replace user defined annotations (mostly in Extbase) added
#2

Updated by Susanne Moog over 3 years ago

  • Category set to Logging
#3

Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57956

#4

Updated by Anonymous over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF