Bug #83443

Limit length of details in system info box

Added by Michael Schams almost 2 years ago. Updated 6 months ago.

Status:
Under Review
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2017-12-29
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In case some details shown in the system information box are extraordinary long (e.g. the PHP version string), the values exceed the limits of the box.

The example in the attached screenshot originates from a standard Debian GNU/Linux 9 (Stretch) installation with the PHP 7.2 packages from Ondrej Sury https://deb.sury.org - a commonly used source for PHP version 7.2 under Debian (and therefore we will likely see long PHP version strings in TYPO3 v9).

typo3-be-sysinfo-box.png View (72.7 KB) Michael Schams, 2017-12-29 03:45

screenshot0001.png View - in TYPO3 v8.7.16 (41.9 KB) Michael Schams, 2018-06-12 21:38

screenshot0002.png View - in TYPO3 v9.3.0 (31.3 KB) Michael Schams, 2018-06-12 21:38

TYPO3v9.5.0-SystemInfoBox.png View (93.1 KB) Michael Schams, 2018-10-04 23:41

TYPO3v9.5.0-EnvironmentOverview.png View (91.3 KB) Michael Schams, 2018-10-04 23:41


Related issues

Related to TYPO3 Core - Bug #88522: Ugly scrollbar in "System Environment" modal for very long version strings Resolved 2019-06-07

Associated revisions

Revision cb6096f3 (diff)
Added by Andreas Fernandez almost 2 years ago

[BUGFIX] Break too long values in Application Information

Some values in the Application Information toolbar menu are too long any
may exceed the box's width. The CSS is adjusted to break too long
strings.

Also, for better readability for very long values, the alignment is
changed from `middle` to `top`.

Resolves: #83443
Releases: master, 8.7
Change-Id: Ia85e92e086525c8f66fd8ab225160dfbdb313a73
Reviewed-on: https://review.typo3.org/55258
Tested-by: TYPO3com <>
Tested-by: Michael Schams <>
Reviewed-by: Mathias Brodala <>
Tested-by: Mathias Brodala <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

Revision 8a5b3209 (diff)
Added by Andreas Fernandez almost 2 years ago

[BUGFIX] Break too long values in Application Information

Some values in the Application Information toolbar menu are too long any
may exceed the box's width. The CSS is adjusted to break too long
strings.

Also, for better readability for very long values, the alignment is
changed from `middle` to `top`.

Resolves: #83443
Releases: master, 8.7
Change-Id: Ia85e92e086525c8f66fd8ab225160dfbdb313a73
Reviewed-on: https://review.typo3.org/55315
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision e5e93a30 (diff)
Added by Andreas Fernandez almost 2 years ago

[FOLLOWUP][BUGFIX] Break too long values in Application Information

`break-all` breaks the text in the cache menu. Use `break-word` to keep whole words intact.

Resolves: #83443
Releases: master, 8.7
Change-Id: I060a3cc3d3461233d93a4b08ff6cf4ec96f0edda
Reviewed-on: https://review.typo3.org/55320
Reviewed-by: Jan Helke <>
Tested-by: Jan Helke <>
Reviewed-by: Wouter Wolters <>
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision 0ba14b9c (diff)
Added by Andreas Fernandez almost 2 years ago

[FOLLOWUP][BUGFIX] Break too long values in Application Information

`break-all` breaks the text in the cache menu. Use `break-word` to keep whole words intact.

Resolves: #83443
Releases: master, 8.7
Change-Id: I060a3cc3d3461233d93a4b08ff6cf4ec96f0edda
Reviewed-on: https://review.typo3.org/55325
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Riccardo De Contardi almost 2 years ago

what about adding to the CSS:

.dropdown-table-value{
 word-break: break-word;
}

#2 Updated by Gerrit Code Review almost 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55258

#3 Updated by Gerrit Code Review almost 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55258

#4 Updated by Gerrit Code Review almost 2 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55315

#5 Updated by Andreas Fernandez almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Gerrit Code Review almost 2 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55320

#7 Updated by Andreas Fernandez almost 2 years ago

  • Status changed from Under Review to Resolved

#8 Updated by Gerrit Code Review almost 2 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55325

#9 Updated by Andreas Fernandez almost 2 years ago

  • Status changed from Under Review to Resolved

#10 Updated by Andreas Fernandez over 1 year ago

  • Status changed from Resolved to New

Michael Schams just pinged me, the issue is not completely solved.

#11 Updated by Michael Schams over 1 year ago

Re-open ticket: issue re-appeared.

∎ reproducible in TYPO3 v8.7.10
∎ reproducible in TYPO3 v8.7.16
∎ reproducible in TYPO3 v9.3.0 (maybe earlier)

See attached screenshot0001.png and screenshot0002.png.

#12 Updated by Riccardo De Contardi about 1 year ago

  • Status changed from New to Needs Feedback

What browser are you using?

can you test it with the latest 8.7 and 9.5 ? I am not able to reproduce it using Chrome (latest) on MAC.

#13 Updated by Michael Schams about 1 year ago

Issue occurs with Firefox Quantum 60.2.2esr (64-bit), but I can confirm it works fine in Chrome.
2x new screenshots attached (TYPO3 9.5.0 + Firefox Quantum).

#14 Updated by Riccardo De Contardi about 1 year ago

  • Status changed from Needs Feedback to New

Oh, yes thank you! It seems that Firefox does not support word-break: break-word; instead you should use overflow-wrap: break-word; (https://stackoverflow.com/questions/4282757/how-can-i-make-firefox-word-break-with-css)

Plus, it still does not work inside the div that has a display:table-cell

I found this combination that should work:

.dropdown-table{
     table-layout:fixed;
}

.dropdown-table-column{
    word-break:break-word;
    overflow-wrap:break-word;
}

#15 Updated by Gerrit Code Review 8 months ago

  • Status changed from New to Under Review

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60428

#16 Updated by Gerrit Code Review 8 months ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60428

#17 Updated by Riccardo De Contardi 6 months ago

  • Related to Bug #88522: Ugly scrollbar in "System Environment" modal for very long version strings added

#18 Updated by Riccardo De Contardi 6 months ago

can be abandoned? This should be solved with https://review.typo3.org/c/Packages/TYPO3.CMS/+/61041

Also available in: Atom PDF