Bug #83501

Non-existing file storage ID 1 breaks BaseSetup => "No accessible form storage folders"

Added by Christian Rieke 9 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2018-01-07
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:
Remote Sprint

Description

Flie mount ID 1 is hardcoded in BaseSetup.yaml

allowedFileMounts:
10: 1:/user_upload/

If a file mount ID 1 does not exist, form fails with "No accessible form storage folders" message.

Although, according to the core AccessControl documentation, hardcoding the file mount ID looks like the official way to do it, this is the first time that I experience a TYPO3 function to actually break by doing it.

History

#1 Updated by Christian Rieke 9 months ago

  • Subject changed from Non-existing file mount ID 1 breaks BaseStup => "No accessible form storage folders" to Non-existing file storage ID 1 breaks BaseStup => "No accessible form storage folders"

CORRECTION:
file storage with ID 1 must exist (not file mount)

#2 Updated by Bjoern Jacob 7 months ago

  • Sprint Focus set to Remote Sprint

#3 Updated by Bjoern Jacob 7 months ago

  • Subject changed from Non-existing file storage ID 1 breaks BaseStup => "No accessible form storage folders" to Non-existing file storage ID 1 breaks BaseSetup => "No accessible form storage folders"

#4 Updated by Bjoern Jacob 7 months ago

  • Status changed from New to Closed

If a file mount ID 1 does not exist, form fails with "No accessible form storage folders" message.

Normally, this is not the case. In a fresh TYPO3 installation, there is always a file storage with uid 1. The storage is auto-created. Please make sure that the storage 1 exists in your installation.

Also available in: Atom PDF