Bug #83545

rte_ckeditor: Link-update-button disappears in link-browser

Added by Peter Benke 11 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2018-01-12
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

Hello together,

editing links in rte_ckeditor:

  • Create an intern link
  • Edit this intern link (the link browser popup comes again) => there is an update-button
  • Select antother tab in the link browser popup, e.g. "External URL"
  • Go back to the tab "Page"

=> The update-button has gone...

Thank you.


Related issues

Related to TYPO3 Core - Bug #83262: Linkhandler popup forgets all settings after switching tabs Closed 2017-12-08

Associated revisions

Revision 45ba7fd3 (diff)
Added by Joerg Kummer about 2 months ago

[BUGFIX] Keep update button in linkbrowser for RTE CKEditor on edit

This patch moves the current value of the link into the parameter array
for the linkbrowser to keep the value in all linked actions inside the
linkbrowser for the RTE CKEditor.

This keeps the update button in the page linkhandler,
if an existing page link will be edited.

Resolves: #83545
Releases: master, 8.7
Change-Id: Ia9217057e45a5d94668bb5ac2f111198da9a69d1
Reviewed-on: https://review.typo3.org/58737
Reviewed-by: Daniel Goerz <>
Tested-by: Daniel Goerz <>
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

Revision 05ffc756 (diff)
Added by Joerg Kummer about 2 months ago

[BUGFIX] Keep update button in linkbrowser for RTE CKEditor on edit

This patch moves the current value of the link into the parameter array
for the linkbrowser to keep the value in all linked actions inside the
linkbrowser for the RTE CKEditor.

This keeps the update button in the page linkhandler,
if an existing page link will be edited.

Resolves: #83545
Releases: master, 8.7
Change-Id: Ia9217057e45a5d94668bb5ac2f111198da9a69d1
Reviewed-on: https://review.typo3.org/58760
Reviewed-by: Joerg Kummer <>
Tested-by: Joerg Kummer <>
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Riccardo De Contardi 5 months ago

This issue is still present in 9.4-dev (latest master)

#2 Updated by Susanne Moog about 2 months ago

  • Sprint Focus set to On Location Sprint

#3 Updated by Jasmina Ließmann about 2 months ago

I can confirm this issue on the current master (9.5.1-dev) as well.

#4 Updated by Joerg Kummer about 2 months ago

Same behavior in TYPO3 version 8.7.19 and 7.6.32

#5 Updated by Gerrit Code Review about 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58737

#6 Updated by Gerrit Code Review about 2 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58737

#7 Updated by Gerrit Code Review about 2 months ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58760

#8 Updated by Joerg Kummer about 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Joerg Kummer 8 days ago

  • Related to Bug #83262: Linkhandler popup forgets all settings after switching tabs added

Also available in: Atom PDF