Project

General

Profile

Actions

Task #84140

closed

Disable Save buttons if record is reloading after field change

Added by Markus Sommer almost 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2018-03-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
Sprint Focus:

Description

Expected Behavior

As User i create an new record (eg. filemount) and change a field that required a reload (eg. storage) i wont to see a progress (Disable save button or other)

Actual Behavior

2 records will be created if the user do not wait for the reload after a field change.

Steps to Reproduce the Problem

1. Create new filemount
2. Select a storage
3. Do not wait for the reload and Press the Save Button
4. See in the Record List you will get 2 new records


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #80672: Saving problems in Chrome 57+Closed2017-04-04

Actions
Actions #1

Updated by Markus Sommer almost 6 years ago

  • Tracker changed from Feature to Task
  • TYPO3 Version set to 8
Actions #2

Updated by Wouter Wolters almost 6 years ago

  • Target version deleted (8.7.11)
Actions #3

Updated by Oliver Bartsch over 3 years ago

  • Related to Bug #80672: Saving problems in Chrome 57+ added
Actions #4

Updated by Oliver Bartsch over 3 years ago

  • Status changed from New to Needs Feedback

Hi,

could you please test if this issue is still present as with #80672 a so called "UI blocker" was introduced which prevents the user from pressing the save button while the FormEngine is loading.

Actions #5

Updated by Riccardo De Contardi about 3 years ago

  • Status changed from Needs Feedback to Closed

There has been no feedback since 90+ days; I guess it is safe to close this one for now.

If you think that this is the wrong decision and experience the issue again on more recent TYPO3 versions (9 or 10 or 11) please open a new issue with a reference to this one

Thank you.

Actions

Also available in: Atom PDF