Project

General

Profile

Actions

Bug #80672

closed

Story #69617: FormEngine bugs

Saving problems in Chrome 57+

Added by Stephan Auer about 7 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Start date:
2017-04-04
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
hard
Is Regression:
No
Sprint Focus:

Description

Hi TYPO3 Community!

Since one of the last Google Chrome Browser updates there are existing saving problems in the backend.
That is the way I can reproduce it:

  • Setup a plain TYPO3 7.6 project in the current minor version. I did so with composer.
  • Update your Google Chrome to the newest version or download it.
  • Install the backend user administration and try to create a backend usergroup
  • If the create process is working - try to rename the group multiple times
  • You can test it with similar other saving processes (tt_content, page settings, ...)

In my case ~25% of the saving processes did fail. I tried Chrome on Windows 10 and MacOS in the current version. I also tried on multiple other TYPO3 7.6 LTS projects with the same result.

The problem does not occur on Firefox, IE 11 and Safari (so I guess only at Chrome).
My exact Chrome Version: 57.0.2987.133

I am aware that this might also be a Chrome problem but I am curious if other people out there can also reproduce this error!

Thank you for your help and work!
Kind regards
Stephan


Related issues 7 (0 open7 closed)

Related to TYPO3 Core - Bug #80632: still issues with missing input in BEClosed2017-04-02

Actions
Related to TYPO3 Core - Bug #80366: Values aren't always saved in the TYPO3 backendClosedMarkus Klein2017-03-21

Actions
Related to TYPO3 Core - Bug #80884: FAL metadata has to save multiple times before it's go to the databaseClosed2017-04-19

Actions
Related to TYPO3 Core - Bug #80481: FormEngine.Validation may access DOM too earlyClosedMarkus Klein2017-03-27

Actions
Related to TYPO3 Core - Bug #77729: Save Button must be disabled until formengine form is fully loadedClosed2016-09-01

Actions
Related to TYPO3 Core - Task #84140: Disable Save buttons if record is reloading after field changeClosed2018-03-05

Actions
Has duplicate TYPO3 Core - Bug #80998: TCA validation in backend failedClosed2017-04-25

Actions
Actions #1

Updated by Wittkiel Gruppe about 7 years ago

Duplicate of #80366?

Actions #2

Updated by Damian Parpan almost 7 years ago

Hi Stephan, hi community!

I can reproduce the problem. In every backend form I have tried so fare, your description of the saving issue happens.
What I noticed: if i write some text in an input field, then place my curser in an other field, the content is saved. If the curser stays in the field, it is not saved.

Tried it with Firefox and Safari on the Mac, IE 11 and Edge and on Windows: the problem does not occur there.

My Chrome version (Mac): 57.0.2987.133 (64-bit)
TYPO3 versions the problem occurs: 7.6.12, 7.6.16, 8.6.1

Some of my clients have the same problem with their Chrome (on Windows mostly).

Greetings
Damian

Actions #3

Updated by Riccardo De Contardi almost 7 years ago

I think I can confirm it for 8.7.0

Actions #4

Updated by Mona Muzaffar almost 7 years ago

  • Related to Bug #80632: still issues with missing input in BE added
Actions #5

Updated by Mona Muzaffar almost 7 years ago

  • Related to Bug #80366: Values aren't always saved in the TYPO3 backend added
Actions #6

Updated by Pascal Hinz almost 7 years ago

  • Related to Bug #80884: FAL metadata has to save multiple times before it's go to the database added
Actions #7

Updated by Riccardo De Contardi almost 7 years ago

  • Category set to FormEngine aka TCEforms
  • Parent task set to #69617
Actions #8

Updated by Tymoteusz Motylewski almost 7 years ago

@Damian, please try with most recent v7.6.18 version.

There were 2 patches in that area which were included in 7.6.17.
[BUGFIX] JS: Invert dependency definition for FormEngine and Validation (Markus Klein)
[BUGFIX] JS: Fix FormEngine initialization (Markus Klein)

Actions #10

Updated by Tobias Schmidt almost 7 years ago

To avoid confusion: This is not fixed in TYPO3 CMS 7.6.18. See #80884-9 for a possible Bugfix.

Actions #11

Updated by Markus Klein almost 7 years ago

  • Related to Bug #80481: FormEngine.Validation may access DOM too early added
Actions #12

Updated by Lars Peter Søndergaard almost 7 years ago

I don't seem to be able to reproduce the issue on latest Chrome 58.x (neither in 8.7.1 nor 7.6.18)

Can someone confirm?

Actions #13

Updated by Riccardo De Contardi almost 7 years ago

Unable to reproduce so far with Chrome 58 and latest Master (MAC)

Actions #14

Updated by Anders Kostending almost 7 years ago

I've been able reproduce this issue in Chrome 58.
It is easier to reproduce if the throttle is set to 3G or something like that.

Actions #15

Updated by Christer V almost 7 years ago

How to reproduce:
  • In Chrome set throttling to Regular 3G or slower
  • Add new element
  • Before JS is done loading fill a input field and click away
  • Save
  • The input entered is lost since the the hidden field isn't filled, since the onchange is set to late
Actions #16

Updated by Markus Klein almost 7 years ago

  • Subject changed from [Backend] Saving problems in Chrome 57 to Saving problems in Chrome 57+
  • Status changed from New to Accepted
  • Priority changed from Should have to Must have
  • Target version set to Candidate for patchlevel
Actions #17

Updated by Gerrit Code Review almost 7 years ago

  • Status changed from Accepted to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52613

Actions #18

Updated by Riccardo De Contardi almost 7 years ago

  • Related to Bug #77729: Save Button must be disabled until formengine form is fully loaded added
Actions #19

Updated by Georg Ringer almost 7 years ago

  • Has duplicate Bug #80998: TCA validation in backend failed added
Actions #20

Updated by Gerrit Code Review almost 7 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52613

Actions #21

Updated by Gerrit Code Review almost 7 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52613

Actions #22

Updated by Gerrit Code Review almost 7 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52613

Actions #23

Updated by Urs Braem almost 7 years ago

I experience this in a non-https site, very dominantly when editing BE users; chrome is displaying the "Not Secure" Warning.
Another site with https, same TYPO3 version 7.6.16, has no such issues.
Could it be related?

Actions #24

Updated by Sven Liebendahl almost 7 years ago

Christer V wrote:

How to reproduce:
  • In Chrome set throttling to Regular 3G or slower
  • Add new element
  • Before JS is done loading fill a input field and click away
  • Save
  • The input entered is lost since the the hidden field isn't filled, since the onchange is set to late

Can confirm that for Chrome 57 and 8.7. Mainly the header field in content elements is affected.
When there is a header and bodytext field, saving for the bodytext field is always fine – for the header field not.

Actions #25

Updated by Andreas Allacher almost 7 years ago

With 7.6.16 and chrome 57 I sometimes had the issue that bodytext formatting like bold was lost but the text itself was store.
Hiwever that might have been fixed with the JS fixes in 7.6.17.

Actions #26

Updated by Gerrit Code Review almost 7 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52613

Actions #27

Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52776

Actions #28

Updated by Frank Nägler almost 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #29

Updated by Gerrit Code Review almost 7 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52777

Actions #30

Updated by Frank Nägler almost 7 years ago

  • Status changed from Under Review to Resolved
Actions #31

Updated by José Ricardo almost 7 years ago

We have applied the patch.

What we could see it that this solves the problem but creates another: the overlay is on "loading" forever on some Google Chrome (windows). I didn't tested a lot, but on a local machine with the test server in the same network (no speed problems), the result was not being able to edit the form even after waiting for more than 5 minutes. :/ (TYPO3 7.6.18)

It worked on my local Chrome (Ubuntu), however.

Actions #32

Updated by Riccardo De Contardi almost 7 years ago

@José Ricardo I had the same problem.... IIRC I solved it reloading the backend with clearing the browser cache

Actions #33

Updated by José Ricardo almost 7 years ago

Cleaning the cache solved. Thanks!

Actions #34

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions #35

Updated by Oliver Bartsch over 3 years ago

  • Related to Task #84140: Disable Save buttons if record is reloading after field change added
Actions

Also available in: Atom PDF