Bug #84142

Forms interfering when using the same form multiple times on one page

Added by Markus Mächler almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2018-03-05
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

It is currently not possible to use the same form multiple times on a single page without interference of the forms. How to reproduce:

1. Create a form with two pages
2. Create two form plugins on the same page and choose form from step 1 for both plugins
3. Navigate to the second page of the first form
4. Result: both forms are no on page 2

There are more issues with this:
- Values entered in one form are also present in the second form
- Finisher emails are sent two times

The problem is that forms are not treated uniquely by plugin integration, but just by form definition. E.g. form field names just use the form name as prefix: tx_form_formframework[form_name][field_name]

In my opinion it should be possible to use the same form multiple times on the same page but with different finishers set on the corresponding plugin content element. A common use case for instance is a contact form that has different recipients depending on the issue.


Related issues

Related to TYPO3 Core - Feature #81775: EXT:form - add the possibilty to use the same form multiple times on one page Closed 2017-07-03

History

#1 Updated by Ralf Zimmermann almost 2 years ago

  • Related to Feature #81775: EXT:form - add the possibilty to use the same form multiple times on one page added

#2 Updated by Ralf Zimmermann almost 2 years ago

This issue is fixed since TYPO3 v9.0.

#3 Updated by Markus Mächler almost 2 years ago

Ralf Zimmermann wrote:

This issue is fixed since TYPO3 v9.0.

Thanks for the response! Will this fix also be available for TYPO3 8 LTS?

#4 Updated by Bjoern Jacob almost 2 years ago

  • Status changed from New to Closed

This change was a feature which cannot be backported to TYPO3 v8. We are very sorry.

Also available in: Atom PDF