Project

General

Profile

Actions

Bug #84266

closed

DatabaseRecordLinkBuilder doesn't unset $conf['parameter']

Added by Tizian Schmidlin almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
Start date:
2018-03-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
typolink
Complexity:
Is Regression:
Sprint Focus:

Description

According to documentation, I should be able to configure the recordLink handler as follows:

config.recordLinks {
    tx_news {
        typolink {
            parameter = {$PID.newsPage}
            additionalParams.data = field:uid
            additionalParams.wrap = &id={$PID.newsPage}&tx_news_pi1[controller]=News&tx_news_pi1[action]=detail&tx_news_pi1[news]=|
            useCacheHash = 1
            ATagParams.data = parameters:allParams
            target.data = parameters:target
            title.data = parameters:title
            extTarget = _blank
            extTarget.override.data = parameters:target
        }
        forceLink = 1
    }
}

This doesn't work since DatabaseRecordLinkBuilder also creates a parameter element in its config which, when merged with above configuration results in a parameter value that is an array instead of a string (which would be expected by typoLink).

In order to solve this, something has already been done in on line 64 by unsetting $conf['parameter.']. When unsetting $conf['parameter'] everything seems to be fine (I'll attach a patch file later).

Feel free to ask if anything is unclear.

Best Regards
Tizian


Files

84266.diff (796 Bytes) 84266.diff Tizian Schmidlin, 2018-03-14 17:13

Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #84116: Linkhandler links not rendered in frontend when TSConfig configuration is applied using "registerPageTSConfigFile()" or "addPageTSConfig()"Closed2018-03-02

Actions
Actions #1

Updated by Tizian Schmidlin almost 6 years ago

Here the patch file

Actions #2

Updated by Tymoteusz Motylewski almost 6 years ago

Hi Tizian,
1.Can you please add a steps how can I reproduce the issue?
2. Does this issue occurs with TYPO3 v8 or v9 too?
3. can you push the patch to our review system - https://review.typo3.org
please see documentation on how to contribute https://docs.typo3.org/typo3cms/ContributionWorkflowGuide/WorkflowExplained/Index.html
If you have any issues, just let me know here or on https://typo3.slack.com channel #typo3-cms-coredev

Actions #3

Updated by Tizian Schmidlin almost 6 years ago

Hi,

as stated in the ticket information, this happens with TYPO3 8.

The issue is reproducible like this:
- install news
- configure as stated in TYPO3 documentation for record links
- add above typoscript for rendering

Any link that is set to be resolved from <f:link.typolink> will fail with an exception.

I'll push my change to gerrit asap.

Actions #4

Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56435

Actions #5

Updated by Gerrit Code Review almost 6 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56436

Actions #6

Updated by Gerrit Code Review almost 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56436

Actions #7

Updated by Susanne Moog almost 6 years ago

  • Is duplicate of Bug #84116: Linkhandler links not rendered in frontend when TSConfig configuration is applied using "registerPageTSConfigFile()" or "addPageTSConfig()" added
Actions #8

Updated by Susanne Moog almost 6 years ago

  • Status changed from Under Review to Closed
Actions #9

Updated by Tizian Schmidlin almost 6 years ago

Hello Susie,

thanks for your feedback, happy to see that this was already fixed when I posted it :-)

The new slogan of the T3 Core team should be "TYPO3, we solve issues you've found before you report them!"

Thanks

Regards
Tizian

Actions

Also available in: Atom PDF